[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] PCI bus scan failure on 3.0.0 testing

Hi All,

I've a set of machines (Network Engines, equivalent to IBM 4000R's)
which worked fine using the default configs for all versions of Xen
from 1.0 thru 2.0 testing, with both the 2.4 and 2.6 kernel; I'm
trying to upgrade to 3.0.0 (xen-3.0-testing.hg changeset 8269), but am
now having trouble with PCI bus scanning -- only the first bus is
found.  I've tried several permutations of nosmp, acpi=off, and noapic
on both the Xen and Linux command line, and have tried various things
like pci=noacpi,scanbus,lastbus=2 on the Linux command line; no luck
so far.  (Without nosmp, acpi=off, and noapic I tend to get hangs; I
never needed to use those before.)

Does anyone recognize this problem, and/or have any suggestions for
what to try next?  I keep feeling like I'm missing something obvious,
but haven't spotted it so far.  

Attached are the boot messages for:
    xen 2.0 with 2.4 kernel    (works)
    xen 2.0 with 2.6.11 kernel (works)
    xen 3.0 with 2.6.12 kernel (panics)

I'll keep poking at this (I desperately need to get it working), and
trying other permutations of kernels and boot options; if anyone can
provide any hints for how to debug this I'd appreciate it a great


Stephen G. Traugott  (KG6HDQ)
UNIX/Linux Infrastructure Architect, TerraLuna LLC
http://www.stevegt.com -- http://Infrastructures.Org

Attachment: xen2.0-2.4-good
Description: Text document

Attachment: xen2.0-2.6-good
Description: Text document

Attachment: xen3.0-2.6.12-bad
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.