[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] RE: [Xen-ia64-devel] Paravirtualized xenlinux/ia64 available

Yes, like real Linux/ia64, it is not possible to run the
same Xenlinux bits both on ski and on real hardware.
A different configuration and build is required.  The
config difference is the same as it was with the
privified xenlinux... I think you did that successfully
before (with privified xenlinux) so give that config
file a try and if it doesn't work, let me know.

BTW, I think I know how to fix this problem (unable
to run same bits on ski and real hardware) for real
Linux/ia64 and Xen/ia64, but it would take a day or
two and hasn't bubbled up to the top of my list yet.


P.S. Please move further replies on this topic
to xen-ia64-devel only.

> -----Original Message-----
> From: Tian, Kevin [mailto:kevin.tian@xxxxxxxxx] 
> Sent: Friday, May 13, 2005 2:35 AM
> To: Magenheimer, Dan (HP Labs Fort Collins); 
> xen-ia64-devel@xxxxxxxxxxxxxxxxxxx; xen-devel
> Cc: Munoz, Alberto J
> Subject: RE: [Xen-ia64-devel] Paravirtualized xenlinux/ia64 available
> Hi, Dan,
>       We tried latest xeno-unstable-ia64 bk tree on a para-virtualized
> dom0 following your instructions. However it failed to find root fs on
> ski:
> VFS: Cannot open root device "<NULL>" or unknown-block(8,2)
> Please append a correct "root=" boot option
> Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(8,2)
>       The bk info is:
>   ChangeSet@xxxxxx, 2005-05-10 15:58:27-07:00, xen-ia64.adm@xxxxxxxxxx
>   Merge bk://xen.bkbits.net/xeno-unstable.bk
>   into  bkbits.net:/repos/x/xen-ia64/xeno-unstable-ia64.bk
>       However we then tried previous binary-patched dom0 with code in
> our trunk (VTI disabled), it can work to user prompt. This 
> means the ski
> environment still working well. 
>       Do you ever see similar error on this revision? Maybe we missed
> some important step or... ski environment needs some change? 
> The command
> to start ski is:
>     "ski bootloader xen paralinux nomca simscsi=`pwd`/sd"
>       Here paralinux is built upon
> bk://xen-ia64.bkbits.net/xenlinux-ia64-2.6.11.bk.
>       BTW, just saw a small bug in vcpu.c:
> IA64FAULT vcpu_itc_d(VCPU *vcpu, UINT64
>               ...
>        if (((itir & ~0xfc) >> 2) < PAGE_SHIFT) {
> Should be:
>        if (((itir & 0xfc) >> 2) < PAGE_SHIFT) {
> Thanks,
> Kevin
> >-----Original Message-----
> >From: xen-ia64-devel-bounces@xxxxxxxxxxxxxxxxxxx
> >[mailto:xen-ia64-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of
> Magenheimer,
> >Dan (HP Labs Fort Collins)
> >Sent: Thursday, May 05, 2005 4:56 AM
> >To: xen-ia64-devel@xxxxxxxxxxxxxxxxxxx; xen-devel
> >Cc: Munoz, Alberto J
> >Subject: [Xen-ia64-devel] Paravirtualized xenlinux/ia64 available
> >

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.