[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Xen-devel] Fix for 'acpi=off'

I am a little confused here. 

I have configured Dom0 to be a uniprocessor kernel. Shouldn't that stop
SMP specific code from being executed?

Won't setting num_processors=1 cause Dom0 to always be uniproc even if
SMP is turned on? 


-----Original Message-----
From: Arun Sharma [mailto:arun.sharma@xxxxxxxxx] 
Sent: Thursday, May 05, 2005 7:10 PM
To: Puthiyaparambil, Aravindh
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Fix for 'acpi=off'

Puthiyaparambil, Aravindh wrote:
> I tried the acpi=off on my 2-by x86_64 box running 32-bit SLES9.
> Everything seems to work just fine except for a couple of pfn and page
> fault non-fatal errors.
> But with acpi=ht, Dom0 hangs while trying to bring up the SCSI
> I have included debug output for both cases.

I think this is the issue you're running into:

> SMP mptable: no processors registered!
> BIOS bug, MP table errors detected!...
> ... disabling SMP support. (tell your hw vendor)

With acpi=off acpi_lapic is non-zero so this code works:

    /* ACPI may have already provided this data */
    if (!acpi_lapic)

But with acpi=ht, MP table processor info is ignored. I worked around it
by ignoring the processor entries in the MP table always and setting


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.