[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] VM-Tools 0.0.2

Adam Sulmicki wrote:

FWIW, I grabbed vm-tools-20050220, then I tried to run it with console output

Great :-)

# vm-create -c /boot/vmlinuz-2.6.9-xenU -m 96 -C "/dev/hda1 ro" --attach-vif=aa:00:00:02:00:00 -B 0707:0301
vm-create: invalid option -- c
Try `vm-create --help' for more information.

so I removed "-c" and tried again

Yes. I removed support for '-c' in vm-create in favor of doing it at the vm script level. It just doesn't make sense for vm-create to be exec() another process.

# losetup /dev/loop7 -o  131604480 /usr/src/cm/root/./suse-uml.img
# ls -l /dev/loop7 /dev/hda1
brw-rw----  1 root disk 3, 1 Dec  3 11:50 /dev/hda1
brw-rw----  1 root disk 7, 7 Dec  3 11:50 /dev/loop7

# vm-create /boot/vmlinuz-2.6.9-xenU -m 96 -C "/dev/hda1 ro" --attach-vif=aa:00:00:02:00:00 -B 0707:0301

You're missing the "root=" part of the command line.  It should be:

# vm-create /boot/vmlinuz-2.6.9-xenU -m 96 -C "root=/dev/hda1 ro" --attach-vif=aa:00:00:02:00:00 -B 0707:0301

Configuring device
 Loaded kernel: c0100000->c03784e0
 Init. ramdisk: c0379000->c0379000
 Phys-Mach map: c0379000->c0391000
 Page tables:   c0391000->c0394000
 Start info:    c0394000->c0395000
 Boot stack:    c0395000->c0396000
 TOTAL:         c0000000->c0800000
 ENTRY ADDRESS: c0100000
 VCPUS:         1

This means your system started up properly. While I do not like the fact that libxc dumps out to stdout a lot I have to admit it's very useful :-)

# vm-list
        Name            Status  Memory
        Domain-0        -----r  256MB
        Domain-1        -s----  96MB
        Domain-2        -s----  96MB
        Domain-3        -s----  96MB
# vm-console 3
Opening console for Domain-3. Use Ctrl-] to exit.

I very recently fixed the buffering problems in vm-console. They probably didn't make the last release. I'm planning on updating latest this evening. vm-console was accidently flushing the tty when it opened it up. The output you should be seeing is a VFS error from the kernel.


Anthony Liguori

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.