[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen and reiserfs

WAHOO !!! It worked !!
Beautiful Robin !

Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0        0      121          0  r----        7554.8
suse                 9       64          0  -b---           6.3        9609

Thanks for the help !!!!!
This is a great project ! I'm really looking forward to using this in the future...
Now to go play... :-D
Cheers !

Robin Green wrote:

On Mon, 21 Feb 2005, Jim Martin wrote:

Thanks Robin !
This got me a lot further on..but now I'm seeing this..

Woops! My mistake. Do this instead:

 mkdir /mnt/suse
 mount -t reiserfs -o ro /dev/hdb2 /mnt/suse
 rm -f /boot/initrd-2.6.10-1.1148_FC4xenU.img

 # all on one line
mkinitrd --fstab=/mnt/suse/etc/fstab /boot/initrd-2.6.10-1.1148_FC4xenU.img 2.6.10-1.1148_FC4xenU

 umount /mnt/suse  # DO NOT OMIT THIS STEP!

That should detect the root filesystem type correctly. Then try
xm create again.


[root@groucho xen]# xm create -c suse
Using config file "suse".
Started domain suse, console on port 9607
************ REMOTE CONSOLE: CTRL-] TO QUIT ********
Linux version 2.6.10-1.1148_FC4xenU (bhcompile@xxxxxxxxxxxxxxxxxxxxx) (gcc version 3.4.3 20050209 (Red Hat 3.4.3-19)) #1 SMP Sat Feb 19 15:28:44 EST 2005
BIOS-provided physical RAM map:
Xen: 0000000000000000 - 0000000004000000 (usable)
64MB LOWMEM available.
Using x86 segment limits to approximate NX protection
DMI not present.
IRQ lockup detection disabled
Built 1 zonelists
Kernel command line:  root=/dev/hdb2 ro
Initializing CPU#0


Creating root device
Mounting root filesystem
VFS: Can't find ext3 filesystem on dev hdb2.
mount: error 22 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!
<0>Rebooting in 1 seconds..

[root@groucho ~]# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0      121    0  r----   5515.8
suse               7       64    0  ---s-      1.0    9607



Robin Green wrote:

On Mon, 21 Feb 2005, Jim Martin wrote:

I'm running Xen on Fedora core 3...
uname -a
Linux groucho 2.6.10-1.1148_FC4xen0 #1 SMP Sat Feb 19 15:15:24 EST 2005 i686 i686 i386 GNU/Linux

# xm list
Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0      121    0  r----    140.9

What I'm trying to do is get SuSE 9.2 to come up in it's own domain..
/dev/hda2 = root for FC-3
/dev/hdb2 = root for SuSE 9.2

My config file in /etc/xen (suse)
# cat suse
kernel ="/boot/vmlinuz-2.6.10-1.1148_FC4xenU"
memory = 64
name = "suse"
nics = 1
disk = ['phy:hdb2,hdb2,w']
root = "/dev/hdb2 ro"

My problem...
When I run 'xm create -c suse' everything seems fine right up to the point of
mounting root and I get this error:
md: ... autorun DONE.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,66)
<0>Rebooting in 1 seconds..

This is a reiserfs /dev/hdb2 - does this xen kernel support reiserfs ?
Or is my config file wrong ?

Xen kernels have no problem with reiserfs (indeed, they should work with any filesystem). Your problem is due to the fact that you are booting with a Fedora kernel, which unlike (IIRC) the suse kernels, has reiserfs as a
module, not compiled in.

Not to worry, all you have to do is add an initrd line. Unfortunately,
the kernel-xenU package from Fedora does not currently ship with an initrd, so I think you'll have to build one yourself. Try this command
(I haven't tested it, but it should work):

 mkinitrd /boot/initrd-2.6.10-1.1148_FC4xenU.img 2.6.10-1.1148_FC4xenU

Then add


to your config file in /etc/xen.

The kernel will load the necessary module(s) automatically so it should
not be necessary to modify the initrd produced by mkinitrd.

Hope this helps,

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.