[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Invalid or unsupported executable format, or is it a reiserfs problem?

> I have reinstalled that machine with a ext3 /boot partition and a
> reiserfs / partition
> /dev/hda1  /boot (ext3)
> /dev/hda2 swap
> /dev/hda4 /  (reiserfs)
> Installation from source
> tar xvf xen-2.0.4.tgz
> cd xen-2.0
> make world
> make install
> mkinitrd -o /boot/initrd.img-2.6.10-xen0 2.6.10-xen0
> Edit menu.lst in /boot/grub
> add serial support for grub:
> serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
> terminal --timeout=5 serial console
> Entry for Xen:
> title Xen-2.0
> root (hd0,0) # also tried without
> kernel /xen.gz dom0_mem=64000
> module /vmlinux-2.6.10-xen0 root=/dev/hda4 ro console=tty0
> console=ttyS0,115200n8
> module /initrd.img-2.6.10-xen0 #also tried without
> Connect to another host with null modem cable.
> start minicom and  configure with serial parameters to 115200,
> parity=no, data=8, stop=1
> hardware flow control = yes
> software flow control = no
> terminal = VT102
> backspace sends BS
> Result:
> -------
> The xen kernel does not boot
> I don't see anything on the terminal from grub or xenlinux  (I do see
> the output when booting the normal debian kernel)

When you say you see nothing on the terminal from grub or xenlinux, I
presume you mean after the menu pops up? [assuming you have
"timeout=10" or similar at the top of your grub.conf]

Can you try entering the interactive mode when the menu pops 
up and typing "blocklist /xen.gz" ?



SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.