[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Re: fdisk hard drive image

I tried with this (/img is my hard drive image):

disk = ['/img,hda,w']

This should be:
disk = ['file:/img,hda,w']
It's what i did. Sorry, i did a typo in my first post.

otherwise the tools don't know what kind of backing you want for the VBD.

disk = ['phy:loop3,hda,w'], loop3 is /img attached to /dev/loop3 by

That should just work if the setup of /dev/loop3 worked OK. Can you mount /dev/loop3 in dom0 OK?

Can you please post what errors you're getting from these attempts?

In both case i get the same result,
no error. But, i can't open /dev/hda with fdisk.
I've juste one partition in /proc/partitions called /dev/hda0.



SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.