[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] xen 2.0 testing idle_loop -and -03

1) extreme slowness

'cat /proc/xen/balloon' will tell you how much memory your domain has.
You'll see the current allocation is somewhat less than the 'requested
target'. This is because the backend I/O drivers steal some kernel
address space and the RAM that was mapped in that space is freed back
to Xen. I wouldn't expect the current allocation to be more than maybe
6MB lower than the 64MB target though.

Also, what does 'cat /proc/meminfo' look like?

attached meminfo, balloon and output of both, all of them right after starting dom0

also attached outout of dmesg which shows oom-killer in action (already!) as well as output of "echo m > /proc/sysrq-trigger"

2) won't boot on p3 with compiled for for cyrix

Has that ever worked? I did recently fix a problem with
CONFIG_X86_USE_3DNOW, so were you testing a very up to date version of
the repository? If you are totally stuck send me your .config and I
can build and test.

yeah, it worked just fine on xen 2.0 release. I could compile kernel with
CONFIG_MCYRIXIII and then run the same kernel on both P3 and via (with
some special patches). This time the kernel bombed on P3 (have not tried
it on via).

the repository was as of yesterday.

I'll try building with CYRIXIII selected. If that works for me then I
guess it must be something else in your config.

FWIW, I just d/l pristine tree and used almost default config (except the cyrix setting) just especially to see if it is somethin with my config.

Attachment: b1
Description: Text document

Attachment: m1
Description: Text document

Attachment: t1
Description: Text document

Attachment: d1
Description: Text document



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.