[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] kernel boots. filesystem troubles.

  • To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
  • From: "Gregory Newby" <newby@xxxxxxxx>
  • Date: Thu, 6 Nov 2003 12:46:10 -0900
  • Delivery-date: Thu, 06 Nov 2003 21:47:27 +0000
  • List-id: List for Xen developers <xen-devel.lists.sourceforge.net>

On Thu, Nov 06, 2003 at 06:38:21PM +0000, Ian Pratt wrote:
> > Please could you pull and try these two images from the unstable
> > tree that I've just built for you:
> > 
> >  http://www.cl.cam.ac.uk/users/iap10/temp/xenolinux.gz
> >  http://www.cl.cam.ac.uk/users/iap10/temp/image.gz
> I've just updated the prebuilt xenolinux image at this location
> to include ReiserFS support.
> [ However, there was a trivial build problem due to a missing
> include in the asm-xeno/page.h  -- did you see this when adding
> reiserfs to the config? ]

(I don't think I saw this error)

> If these images work, it's definitely a build problem.  They boot
> on my system, but I haven't been able to check whether reiserfs
> works, though I'd expect it to.

Ok - this boots!  Yay!  Yes, this could be something with my build
procedures, but remember that the first time I tried it was with the
kernel & xeno images copied from the CD (they bombed before the domain
0 was started).

Here is the current status with domain 0 filesystem troubles:

- Only the first filesystems mount (note that the ReiserFS on /
mounted fine):

Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda2             16016308   9988792   6027516  63% /
/dev/sda1                46636     18682     25546  43% /boot
shmfs                    48400         0     48400   0% /dev/shm 

- But these did not mount, and I don't know why (my other FS' are
commented out in /etc/fstab):

/dev/sdb1               /tmp            reiserfs        defaults 0 0
/dev/sdc2               /globus         reiserfs        defaults 0 0
/dev/sdh1               /home           reiserfs        defaults 0 0
/dev/sdm1               /data/web02files        reiserfs        defaults 0 0

They did not mount at boot time, and the errors went by too fast
to see (they're not in dmesg or the boot logs in /var/log).

When I try to mount a reiserfs filesystem (i.e., "mount /tmp") from
the running system, the mount just hangs in an IO wait and never comes
back (I can't even kill -9).

- Here's an ext2:
/dev/sdd1                /mnt/d          ext2           defaults 0 1

When I try to mount after the system is running:
# mount /mnt/d
mount: wrong fs type, bad option, bad superblock on /dev/sdd1,
       or too many mounted file systems
       (could this be the IDE device where you in fact use
       ide-scsi so that sr0 or sda or so is needed?)

When I tried to boot with /mnt/d in /etc/fstab, I got an error
about fsck needing to run (which is false), then supposedly
got dumped into single-user mode to run fsck, but in fact
the system hung...no prompt, hard reboot needed.

Yes, these are all SCSI drives, and were configured correctly
(right speed, bus, Mhz...) when the kernel initialized.

I will try to add a domain, but wanted to write here about
the filesystems.  (Also, I now need to reboot to the old
kernel, to get the filesystems back with the domain tools
for 1.1).

If it would help, I could put a different distribution
on this system.  It's SuSE 8.1, which is generally good
but doesn't even include ext3.  RH9 or Debian would
probably do fine.

Thanks again for working on this, and I hope all my analysis
is helpful!
  -- Greg

This SF.net email is sponsored by: SF.net Giveback Program.
Does SourceForge.net help you be more productive?  Does it
help you create better code?   SHARE THE LOVE, and help us help
YOU!  Click Here: http://sourceforge.net/donate/
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.