This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: [rfc] [patch] "frame number" size in hypercall ABI

To: Joe Bonasera <joe.bonasera@xxxxxxx>
Subject: Re: [Xen-devel] Re: [rfc] [patch] "frame number" size in hypercall ABI
From: Keir Fraser <Keir.Fraser@xxxxxxxxxxxx>
Date: Wed, 19 Apr 2006 16:43:51 +0100
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 19 Apr 2006 08:44:12 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <444657FE.2020401@xxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <E1FWBAp-0008KG-7d@host-192-168-0-1-bcn-london> <444657FE.2020401@xxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx

On 19 Apr 2006, at 16:32, Joe Bonasera wrote:

I think the patch looks okay in principle, except I notice a couple of 'framno_t' misspellings. I think 'pfn_t' would be more in keeping with the Xen naming scheme for arbitrary page frame numbers, but perhaps that name is a bit unnecessarily cryptic. What is the immediate problem you're needing to solve?
  -- Keir

Please don't use pfn_t, that's what Solaris already uses internally for
physical frame numbers. In the Xen code for Solaris, I introduced
mfn_t as the corresponding type for Xen's machine frame numbers.
frameno_t is fine, as I can just define mfn_t and frameno_t to be
the same, but conflicting pfn_t's would be problematic.

Fair enough. We should really avoid polluting the typedef namespace with such short names anyway.

 -- Keir

Xen-devel mailing list