This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] XCP 1.1beta - cannot boot from local DVD

To: "Todd Deshane" <todd.deshane@xxxxxxx>
Subject: RE: [Xen-users] XCP 1.1beta - cannot boot from local DVD
From: "Joe Linoff" <jlinoff@xxxxxxxxxx>
Date: Wed, 13 Jul 2011 23:00:41 -0700
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 13 Jul 2011 23:05:17 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <CAMrPLWJwd2rdK1W1-yoiiNWQSi--ttazDFx6eiQv3YtE9GKq_Q@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <8AD4194C251EC74CB897E261038F44789D5703@xxxxxxxxxxxxxxxxxxx> <CAMrPLWJwd2rdK1W1-yoiiNWQSi--ttazDFx6eiQv3YtE9GKq_Q@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcxByvHve52OGagqSXuy/1SWcTpupQAHehfA
Thread-topic: [Xen-users] XCP 1.1beta - cannot boot from local DVD
Hi Todd:

Thank you again. I really appreciate the time you have taken to help me.

> Does your system have HVM support (VT-x or AMD-V)?

Yes but I would prefer to use PV because I thought that it offered better 
performance. Is that correct?

> You could try to do a network install instead.
> http://docs.vmd.citrix.com/XenServer/5.6.0sp2/1.0/en_gb/guest.html#linux_vm_internet_install

Yup. That is what I have done in the past and will have to do again if I can't 
get this working but it seems to imply that one cannot install known templates 
onto an XCP 1.1 server. If that understanding is correct, it seems to 
contradict the statements in the XCP Guest document: 
http://www.xen.org/files/XenCloud/guest.pdf (pg 24).

Is this a bug or simply a misunderstanding on my part (i.e. this only works for 
HVM's)? If it is a bug, what can I do to help fix it?

I should note that the purpose of this experiment was to determine whether I 
could bootstrap my private cloud by installing the cloud master as a VM on the 
first powered up server before the network was setup.

I also wanted to use a similar approach for security testing in a sandbox where 
I want no access to a network because the sandbox has injected exploits which 
could be dangerous. The only network would be local to the server through VM 



-----Original Message-----
From: todd.deshane.xen@xxxxxxxxx [mailto:todd.deshane.xen@xxxxxxxxx] On Behalf 
Of Todd Deshane
Sent: Wednesday, July 13, 2011 7:08 PM
To: Joe Linoff
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] XCP 1.1beta - cannot boot from local DVD

On Wed, Jul 13, 2011 at 7:36 PM, Joe Linoff <jlinoff@xxxxxxxxxx> wrote:
> Hi Folks:
> I am trying to install XCP 1.1beta and a single VM on a computer with no
> network connections. XCP 1.1 installed just fine but I am having trouble
> getting the VM to boot properly from a CentOS 5.5 DVD.

Does your system have HVM support (VT-x or AMD-V)?

I believe that is still needed for XCP + CD/DVD/ISO installs.

You could try to do a network install instead.

> The first problem was that I could not observe what was happening. Todd
> Deshane solved this by showing me how to disable PV VNC and use "xl
> console <dom-id>" to connect. That worked perfectly.
> The current problem is that during the boot process it tells me that it
> does not have a driver for the CD/DVD-ROM but the server boots and
> configure properly when I use the CentOS DVD directly instead of trying
> to create a VM guest which seems to indicate that it has the proper
> drivers.
> How can I debug/fix this?
> My guess is that I made some sort of mistake when configuring the CD-ROM
> but I am not experienced enough to figure it out. Note that the
> DOM0_CD_NAME="SCSI 1:0:0:0" and the DOM0_CD_DEVICE is "1".
> Here is the script that I am using for testing. It simply creates a
> guest called test01.
> At lines 8-12 it makes the dom0 CD device not bootable.
> At lines 14-17 it adds the CD-ROM to the VM. I have also attached the
> console output.
> I got the steps from this URL:
> http://www.xen.org/files/XenCloud/guest.pdf (pg 24): "To install a
> supported Linux VM from vendor media using the CLI".
> What is really strange to me is that it looks like it is recognizing and
> reading the DVD because I had several screens of information that
> required answers before I got to this point.
> % cat -n make-vm.sh
>    1 #!/bin/bash
>    2
>    3 set -x
>    4
>    5 # Create the VM
>    6 VM_UUID=$(xe vm-install template='CentOS 5 (64-bit)'
> new-name-label="test01")
>    7
>    8 # Make the dom0 CD not bootable.
>    9 DOM0_CD_UUID=$(xe vbd-list vm-uuid=$VM_UUID userdevice=0
> params=uuid --minimal)
>   10 xe vbd-param-set uuid=$DOM0_CD_UUID bootable=false
>   11 DOM0_CD_NAME=$(xe cd-list | grep SCSI | sed -e 's/^.*SCSI/SCSI/')
>   12 DOM0_CD_DEVICE=$( echo "$DOM0_CD_NAME" | awk '{print $2;}' | awk
> -F: '{print $1;}')
>   13
>   14 # Add the CD to domU and make it bootable.
>   15 xe vm-cd-add vm=$VM_UUID cd-name="$DOM0_CD_NAME"
> device=$DOM0_CD_DEVICE
>   16 DOMU_CD_UUID=$(xe vbd-list vm-uuid=$VM_UUID type=CD params=uuid
> --minimal)
>   17 xe vbd-param-set uuid=$DOMU_CD_UUID bootable=true
>   18
>   19 # Disable VNC so that we can use xl console
>   20 # URL:
> http://wiki.xensource.com/xenwiki/Xen_Cloud_Platform%3A_Access_to_VM_con
> sole
>   21 # Citation: Todd Deshane
>   22 xe vm-param-set uuid=$VM_UUID other-config:disable_pv_vnc=true
>   23
>   24 # Configuration stuff: use the cd-rom, 2 cpus, 2GB RAM, 20GB disk
> space
>   25 xe vm-param-set uuid=$VM_UUID
> other-config:install-2repository=cdrom
>   26 xe vm-param-set uuid=$VM_UUID VCPUs-max=2 VCPUs-at-startup=2
>   27 xe vm-memory-limits-set uuid=$VM_UUID static-min=2147483648
> 4static-max=2147483648 dynamic-min=2147483648 dynamic-max=2147483648
>   28 xe vm-param-set uuid=$VM_UUID other-config:disks='<provision><disk
> device="0" size="21474836480" sr="" bootable="true" type="system"
> /></provision>'
>   29
>   30 # Set the xenbr0 IP address
>   31 NETW_UUID=$(xe network-list bridge=xenbr0 --minimal)
>   32 xe vif-create vm-uuid=$VM_UUID network-uuid=$NETW_UUID device=0
>   33
>   34 # Start the VM -- boot off of the CD
>   35 xe vm-start uuid=$VM_UUID
> % # Get the DOM id
> % xe vm-list params=dom-id,name-label,uuid
> % # Start the console
> % xl console <dom-id>
> Regards,
> Joe
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Todd Deshane

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>