This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Error of building dom0 kernel

To: Joh Liu <bradevuu@xxxxxxxxx>
Subject: Re: [Xen-users] Error of building dom0 kernel
From: Todd Deshane <todd.deshane@xxxxxxx>
Date: Tue, 5 Jul 2011 22:32:46 -0400
Cc: Jeremy Fitzhardinge <jeremy@xxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 05 Jul 2011 19:33:47 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:sender:in-reply-to:references:from:date :x-google-sender-auth:message-id:subject:to:cc:content-type :content-transfer-encoding; bh=3WpvvWnkTkm3T5/5JiTt+3nJR1yAqBAxsUb069LBasw=; b=Oq0QITY2e1ZELk+uF7alEx4azji6N5TNT6bsObVJlUok/zzAHYbQOdGr/kNQpC/wzq h+uFNEXC7+ow2OI7OTuipyRgkhYWsa3bHEbcpjCBKGElGvvlSEkJwhDKrrHxLGfDhdje yyTgzj39rWZdmDxT6p5lieoUuaCFI3fCZ327M=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <CADpQrfRR-Br0B=Uuso163tfuQjDUSiysGAg=ex+itBBbHAe_Yw@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <CADpQrfRR-Br0B=Uuso163tfuQjDUSiysGAg=ex+itBBbHAe_Yw@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
On Tue, Jul 5, 2011 at 10:06 PM, Joh Liu <bradevuu@xxxxxxxxx> wrote:
> Hi all,
> I follow instructions(http://wiki.xensource.com/xenwiki/XenParavirtOps) to
> build XEN and dom0 kernel. Building XEN has no problem, but there is an
> error which I cannot solve to build dom0 kernel.  The brief instructions for
> building dom0 are get linux-2.6-xen code from git and make ARCH=x86_64
> menuconfig, finally generate kernel.deb. (I did every step exactly as the
> web page says)

So you are pulling from this tree?

git clone git://git.kernel.org/pub/scm/linux/kernel/git/jeremy/xen.git

There are several references to "xen_pcpu_index"

It seems that it has gone unresolved a few times. I'm not sure if this
a known issue or what type of problem it is. Can you provide more
details about your hardware or any other information that may be

You may want to review
http://wiki.xensource.com/xenwiki/AskingXenDevelQuestions as there may
be developers that would be able to shed some light on this issue.
Maybe with the information in the other threads you will gain some
insights about the problem.


> First, compiling linux-2.6-xen is ok.
> (One  error is drivers/char/apg/intel-agp.c, which is solved by replacing a
> new version of intel-agp.c)
> Then when executing (in order to generate .deb)
> sudo fakeroot make-kpkg --initrd --append-to-version=-pv kernel-image
> kernel-headers
> an error occurs:
> Errpr:  Kernel: arch/x86/boot/bzImage is ready  (#1)
> Building modules, stage 2.
> MODPOST 1477 modules
> ERROR: "xen_pcpu_index" [drivers/acpi/processor.ko] undefined!
> WARNING: modpost: Found 1 section mismatch(es).
> To see full details build your kernel with:
> make[1]: *** [__modpost] Error 1
> make: *** [modules] Error 2
> I also tried make ARCH=x86 menuconfig, but it did not work. There are a few
> threads of the same problem, which did not find the actual answer.  My
> machine is Ubuntu8 32-bit(2.6.24-19), i5 processor, XEN-4.0.2. I got stuck
> for several days:(
> I really appreciate your help :_)
> Best,
> Liu
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Todd Deshane

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>