This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Error of building dom0 kernel

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Error of building dom0 kernel
From: Joh Liu <bradevuu@xxxxxxxxx>
Date: Tue, 5 Jul 2011 22:06:51 -0400
Delivery-date: Tue, 05 Jul 2011 19:07:45 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; bh=niGQ5DKMilh3E12T75K1Tdxf8P8GjwXDxZaVkQZdyl4=; b=HQ03YsR4pPMZr80rrfPIgcfBg41Pre/Ua7CbwO9jEVMctVjVlu7FQgOJsM2nPrtS4E oNZSg0+fVUsRxiPIaEFEjvzMutF5GwEawon1TD1obVfX09qlgW01jy43iLjpLLCjghBp gGteDOUZyyUhiqDKjtV0OG1T7ZF8xL5Fm5nco=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi all,

I follow instructions(http://wiki.xensource.com/xenwiki/XenParavirtOps) to build XEN and dom0 kernel. Building XEN has no problem, but there is an error which I cannot solve to build dom0 kernel.  The brief instructions for building dom0 are get linux-2.6-xen code from git and make ARCH=x86_64 menuconfig, finally generate kernel.deb. (I did every step exactly as the web page says)

First, compiling linux-2.6-xen is ok.
(One  error is drivers/char/apg/intel-agp.c, which is solved by replacing a new version of intel-agp.c)

Then when executing (in order to generate .deb)

sudo fakeroot make-kpkg --initrd --append-to-version=-pv kernel-image kernel-headers

an error occurs:

Errpr:  Kernel: arch/x86/boot/bzImage is ready  (#1)
Building modules, stage 2.
MODPOST 1477 modules
ERROR: "xen_pcpu_index" [drivers/acpi/processor.ko] undefined!
WARNING: modpost: Found 1 section mismatch(es).
To see full details build your kernel with:
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2

I also tried make ARCH=x86 menuconfig, but it did not work. There are a few threads of the same problem, which did not find the actual answer.  My machine is Ubuntu8 32-bit(2.6.24-19), i5 processor, XEN-4.0.2. I got stuck for several days:(      

I really appreciate your help :_)

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>