This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] PV networking issue in and 2.6.39-rc7 pvops dom

To: Ian Campbell <Ian.Campbell@xxxxxxxxxxxxx>
Subject: Re: [Xen-users] PV networking issue in and 2.6.39-rc7 pvops dom0 kernels
From: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Date: Tue, 17 May 2011 10:23:49 -0400
Cc: "todd.deshane@xxxxxxx" <todd.deshane@xxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>, Pasi Kärkkäinen <pasik@xxxxxx>, Mario <mario@xxxxxxxxxxxxxx>
Delivery-date: Tue, 17 May 2011 07:25:09 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1305634443.20907.49.camel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4DD120EA.4060204@xxxxxxxxxxxxxx> <1305551216.20907.12.camel@xxxxxxxxxxxxxxxxxxxxxx> <4DD12212.7020403@xxxxxxxxxxxxxx> <4DD12389.1020905@xxxxxxxxxxxxxx> <20110516132231.GS32595@xxxxxxxxxxx> <4DD252AE.6080609@xxxxxxxxxxxxxx> <20110517110440.GU32595@xxxxxxxxxxx> <4DD25A00.6090707@xxxxxxxxxxxxxx> <20110517120902.GV32595@xxxxxxxxxxx> <1305634443.20907.49.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.21 (2010-09-15)
On Tue, May 17, 2011 at 01:14:03PM +0100, Ian Campbell wrote:
> On Tue, 2011-05-17 at 13:09 +0100, Pasi Kärkkäinen wrote:
> > On Tue, May 17, 2011 at 01:20:32PM +0200, Mario wrote:
> > > When i first experienced this problem, it was back when i first tried  
> > > Xen 4.0.1, however, i had just a blank screen with blinking cursor to  
> > > work with. So i had to set up a serial console to figure out what was  
> > > wrong. After seeing how it stops on framebuffer, i blacklisted the  
> > > module, and it worked. I kept on doing so on every other setup i have  
> > > made, but now, one year later, i was wondering if this is ever going to  
> > > be fixed, or if i can somehow help to get it fixed.. :-)

Make sure you attach the full serial log, and include 'drm.debug=255' on your
Linux bootline.
> > >
> > 
> > Yep, you can help by posting the full boot logs from serial console, 
> > both Xen and dom0 linux kernel logs.
> > 
> > http://wiki.xen.org/xenwiki/XenSerialConsole
> > 
> > and: http://wiki.xensource.com/xenwiki/XenParavirtOps, 
> > especially the "Are there more debugging options .." section.
> There's a reasonable chance this is already fixed in one of Konrad's GFX
> branches, although I'm not sure specifically which branch is current.

I think it was the #devel/agp.pci-api but it might need another pass
as it probably doesn't compile anymore :-(

Mario, you could also try to use the VESA fb instead of the s3.

> Ian.

Xen-users mailing list