This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] PV networking issue in and 2.6.39-rc7 pvops dom

To: Mario <mario@xxxxxxxxxxxxxx>
Subject: Re: [Xen-users] PV networking issue in and 2.6.39-rc7 pvops dom0 kernels
From: Pasi Kärkkäinen <pasik@xxxxxx>
Date: Tue, 17 May 2011 15:09:02 +0300
Cc: Ian Campbell <Ian.Campbell@xxxxxxxxxxxxx>, "todd.deshane@xxxxxxx" <todd.deshane@xxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
Delivery-date: Tue, 17 May 2011 05:10:30 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4DD25A00.6090707@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4DD11EF5.1050203@xxxxxxxxxxxxxx> <1305550841.20907.10.camel@xxxxxxxxxxxxxxxxxxxxxx> <4DD120EA.4060204@xxxxxxxxxxxxxx> <1305551216.20907.12.camel@xxxxxxxxxxxxxxxxxxxxxx> <4DD12212.7020403@xxxxxxxxxxxxxx> <4DD12389.1020905@xxxxxxxxxxxxxx> <20110516132231.GS32595@xxxxxxxxxxx> <4DD252AE.6080609@xxxxxxxxxxxxxx> <20110517110440.GU32595@xxxxxxxxxxx> <4DD25A00.6090707@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
On Tue, May 17, 2011 at 01:20:32PM +0200, Mario wrote:
> On 05/17/2011 01:04 PM, Pasi Kärkkäinen wrote:
>> On Tue, May 17, 2011 at 12:49:18PM +0200, Mario wrote:
>>> On 05/16/2011 03:22 PM, Pasi Kärkkäinen wrote:
>>>> On Mon, May 16, 2011 at 03:15:53PM +0200, Mario wrote:
>>>>> On 05/16/2011 03:09 PM, Mario wrote:
>>>>>> On 05/16/2011 03:06 PM, Ian Campbell wrote:
>>>>>>> On Mon, 2011-05-16 at 14:04 +0100, Mario wrote:
>>>>>>>> So you are telling me that 2.6.38 does not have a working networking on
>>>>>>>> PV guests, but HVM does?
>>>>>>> Yes, netback did not go upstream until 2.6.39 so PV networking (either
>>>>>>> for PV or HVM guests with PV drivers) will not work on mainline kernels
>>>>>>> before that.
>>>>>>> Emulated HVM networking does not use netback so that will work on
>>>>>>> earlier kernels (it depends on qemu)
>>>>>>> Ian.
>>>>>> Ok, thanks, it all makes more sense now. :-)
>>>>> Ian, while i have your attention, any idea why some framebuffer devices
>>>>> blank screen when dom0 boots up. I have seen this happen mostly on older
>>>>> vga cards but its not a rule. Should i just keep on blacklisting kernel
>>>>> modules for those cards, or is there some kind of a more general
>>>>> solution?
>>>> You could try "nomodeset" parameter to disable KMS modesetting..
>>>> (and possibly adding "console=tty0")
>>>> Xen patches for DRM/KMS haven't been merged to upstream Linux yet.
>>>> -- Pasi
>>> nomodeset and/or nofb do not seem to help.
>>> console=tty0 also does not seem to have any effect.
>>> Only way to successfuly boot dom0 is with one of these:
>>> or
>>> echo "blacklist s3fb">  /etc/modprobe.d/blacklist-s3fb.conf
>>> As soon as fb device is modprobed, booting stops, and server freezes.
>>> Can anything else be done? Perhaps some setting for xen in kernel..?
>> Set up a serial console and configure Xen + dom0 kernel log to it..
>> and see what goes wrong. http://wiki.xen.org/xenwiki/XenSerialConsole
>> ie. does dom0 kernel crash while loading s3fb?
>> -- Pasi
> Well, i forgot to mention one more method, that is to add: fbcon=map:X
> Where X is something that is not in /proc/fb, basicly an invalid device.
> So, for example: fbcon=map:9
> To make it short, dom0 freezes/crashes and it never reaches a full  
> booted up state, so it will not respond to pings. The last thing  
> displayed on the screen is s3fb being loaded and that /dev/fb0 was 
> created.
> When i first experienced this problem, it was back when i first tried  
> Xen 4.0.1, however, i had just a blank screen with blinking cursor to  
> work with. So i had to set up a serial console to figure out what was  
> wrong. After seeing how it stops on framebuffer, i blacklisted the  
> module, and it worked. I kept on doing so on every other setup i have  
> made, but now, one year later, i was wondering if this is ever going to  
> be fixed, or if i can somehow help to get it fixed.. :-)

Yep, you can help by posting the full boot logs from serial console, 
both Xen and dom0 linux kernel logs.


and: http://wiki.xensource.com/xenwiki/XenParavirtOps, 
especially the "Are there more debugging options .." section.

-- Pasi

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>