This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Unable to boot patched kernel (bzImage not bein

To: Christian Gonzalez <zulsolar@xxxxxxxxx>
Subject: Re: [Xen-users] Unable to boot patched kernel (bzImage not being generated)
From: Richie <listmail@xxxxxxxxxxxx>
Date: Wed, 17 Nov 2010 20:04:41 -0500
Cc: Xen List <Xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 17 Nov 2010 17:05:49 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTinLQtA6JBwsd5Mx9fwHNtix1hgA8Uf9hyAJp=Co@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTinoD5PZ0_fL2E_mMDT1cOS30_28H8F0iy=Z0v=M@xxxxxxxxxxxxxx> <4CE3304E.5060708@xxxxxxxxxxxx> <AANLkTimDfaH7AuLTYo+tVVZhvqkeaMp8N0_dLNkcsKn2@xxxxxxxxxxxxxx> <AANLkTinLQtA6JBwsd5Mx9fwHNtix1hgA8Uf9hyAJp=Co@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101027 Thunderbird/3.1.6
On 11/17/2010 2:13 PM, Fajar A. Nugraha wrote:
On Thu, Nov 18, 2010 at 2:04 AM, Christian Gonzalez <zulsolar@xxxxxxxxx> wrote:

I've tried with but still no luck:

/boot/initrd15.gz: Loading kernel modules from initrd image:
No volume groups found
mount: mounting /dev/rootvg/root on /mnt failed: No such file or directory
Error: No /sbin/init found on rootdev (or not mounted). Trouble ahead. You can try to fix it. Type 'exit; when things are done.

Looks like a kernel config problem to me. Have you ever had a vanilla, non-xen 2.6.34.x kernel boot succefully on that machine?
Also, booting without "quiet" or "vga" on kernel command line arguments should be able to show more of what's happening. Most likely the driver for your disk controller was not loaded, or unable to function properly for some reason. Look for lines showing "sd" or "disk" in the boot process.


Regarding configs, I think all I did was copy a generic kernel config to sourcedir/.config (newer the better) and did a make oldconfig and configure from that point.  It will certainly take longer to compile but that should be the least error prone when it comes to supporting your specific hardware.  Alternatively you could use the .config's posted on the list, I've seen some even for the Xenified kernel.
Xen-users mailing list