This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Unable to boot patched kernel (bzImage not bein

On Thu, Nov 18, 2010 at 2:04 AM, Christian Gonzalez <zulsolar@xxxxxxxxx> wrote:

I've tried with but still no luck:

/boot/initrd15.gz: Loading kernel modules from initrd image:
No volume groups found
mount: mounting /dev/rootvg/root on /mnt failed: No such file or directory
Error: No /sbin/init found on rootdev (or not mounted). Trouble ahead. You can try to fix it. Type 'exit; when things are done.

Looks like a kernel config problem to me. Have you ever had a vanilla, non-xen 2.6.34.x kernel boot succefully on that machine?
Also, booting without "quiet" or "vga" on kernel command line arguments should be able to show more of what's happening. Most likely the driver for your disk controller was not loaded, or unable to function properly for some reason. Look for lines showing "sd" or "disk" in the boot process.

Xen-users mailing list