This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xen upgrade problem, cant boot from 3.4.2 to 4.0.0

To: Daniel <dandadude@xxxxxxxxx>
Subject: Re: [Xen-users] xen upgrade problem, cant boot from 3.4.2 to 4.0.0
From: "Fajar A. Nugraha" <fajar@xxxxxxxxx>
Date: Thu, 9 Sep 2010 15:00:56 +0700
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 09 Sep 2010 01:02:21 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AANLkTim3i8vfM0VY-uoRfFv4Ogvx=XO6nhm6WfY+KuTK@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AANLkTim3i8vfM0VY-uoRfFv4Ogvx=XO6nhm6WfY+KuTK@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
On Thu, Sep 9, 2010 at 1:03 PM, Daniel <dandadude@xxxxxxxxx> wrote:
> Hi Guys!
> I have a very interesting problem.
> I run gentoo and have been running xen-3.4.2 on 2 server computers
> (Supermicro-based, IBM).
> A little time ago, I have tried to upgrade xen-3.4.2 to xen-4.0.0 (with
> emerge) on the Supermicro server, but the computer wasn't able to boot

> - If I set xen-3.4.2.gz in the grub (with installed xen-4.0.0), it is able
> to boot normally, only xend does not start (but I don't need a livecd). This
> means that there is no problem with the kernel, only xen-4.0.0 is the fault
> ;-)

> What do you recommend?

Short version: it's easier to copy what others have succefully done,
and copy it. Hopefuly other Gentoo users can share their experience.

Long version: I haven't used gentoo in a long time, but my guess is
that you run into some xen-and-kernel compatibility problem.
You might want to to update your kernel as well, and/or use Xen 4.0.1.

For comparison, In RHEL/Centos5, the following combination works:
- bundled xen (3.1+) with bundled kernel-xen (2.6.18 + RHEL patches)
- newer xen 3.x (up to 3.4.3, preferably from Gitco repo) with bundled
- Xen 4.0.0 with kernel 2.6.34 +

while using Xen 4.0.0 + RHEL's kernel-xen does not work. I haven't
tested 4.0.1 yet. Also, pv_ops kernel currently require a matching
version of xen, so if you use latest pv_ops kernel for dom0, make sure
you also use latest xen version (4.0.1 or latest xen-testing).


Xen-users mailing list