This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] xen upgrade problem, cant boot from 3.4.2 to 4.0.0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] xen upgrade problem, cant boot from 3.4.2 to 4.0.0
From: Daniel <dandadude@xxxxxxxxx>
Date: Thu, 9 Sep 2010 08:03:44 +0200
Delivery-date: Wed, 08 Sep 2010 23:05:00 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:received:date:message-id :subject:from:to:content-type; bh=NhDeReoLVrAPGpk+J/go9RFjk/s6ahCZiDO0Cxl7S7A=; b=XtRe3/mFvA/rwXgtlJhLcNPHugo9+C+jqkilpq5hBMlFtKv2Lg2w6v4Sko4OONm0IV kZ6Mz4Ia+8+ICCrjFPbvMfHHdOCQwxRJ/sEsQAlJdvAjiZlEVM7cmRpDt1nnCvXA/pnn CvCbkr8UAup2Ak1122di5ez/tLO0g6poOfrgs=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=COuV4caFf7luPBRuADA8qBK8d3HCKMKBIehLaM9hVhf06EpW1g9EytcmrHBWbHubiS 2Jc3xRMKUXJzIrAD6V6/GA/9zkmqGTemWdlBnF/Y2pgoY2F3qcG/Qg0MxXUBV9+pNGoM FDR57s66cf8hBT8fvnugnAORMrxs76Er55QN4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

Hi Guys!

I have a very interesting problem.

I run gentoo and have been running xen-3.4.2 on 2 server computers (Supermicro-based, IBM).

A little time ago, I have tried to upgrade xen-3.4.2 to xen-4.0.0 (with emerge) on the Supermicro server, but the computer wasn't able to boot with the following breakdown:
[ 62.848947] 0800 1315427328 sda driver: sd
[ 62.849264] 0801 208813 sda1
[ 62.849579] 0802 12594960 sda1
[ 62.849938] 0803 10490445 sda1
[ 62.850254] 0804 1292132047 sda1
[ 62.850569] No filesystem could mount root, tried: ext3 vfat msdos iso9660 ntfs fuseblk udf
[ 62.851466] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,3)

Now I thought that there is probably something wrong with me and the specific Supermicro server, but yesterday I have tried to the the same with the IBM server, but this time it hangs after discovering the SAS disk array. It also gives me an error code (IBM x3650 M2)
I have to say a few things about this IBM:
- It hanged before exactly the same, but that was the fresh install, and I left out something from the kernel.
- I have a 100% same IBM server on which I have installed xen-4.0.0 freshly, it works fine.
- The kernels on the 2 IBM servers are identical, every setting is identical.
- If I set xen-3.4.2.gz in the grub (with installed xen-4.0.0), it is able to boot normally, only xend does not start (but I don't need a livecd). This means that there is no problem with the kernel, only xen-4.0.0 is the fault ;-)
- The /etc/xen, /etc/udev is exactly the same on the 2 IBM servers, so this can't be the fault either.
- The funny thing is that I have experienced the same with the Supermicro server too, so it is not hardware specific, but it helps to know that the exact IBM server with fresh xen-4.0.0 and same kernel, same settings, works fine.

What do you recommend?

Oh yeah, I had a thread about this before with the Supermicro, but no luck, I had to downgrade:


Xen-users mailing list