This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] DomU PV network problems

To: "S.M.R. Mahdavian" <mahdavian@xxxxxxxxxxx>
Subject: Re: [Xen-users] DomU PV network problems
From: Sauro Saltini <saltini@xxxxxx>
Date: Wed, 08 Sep 2010 17:21:19 +0200
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 08 Sep 2010 08:20:40 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4C877214.4070202@xxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4C86B3BF.1050308@xxxxxx> <4C877214.4070202@xxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100121 Lightning/1.0b1 Thunderbird/3.0.1
Hi, I've realized just now my first post was sent two times to the list, please ignore this thread and respond only to the other one....

Sorry for the incovenience.


On 08/09/2010 13:23, S.M.R. Mahdavian wrote:
I had a similar problem and I got a kind response from Matej, but I was busy and coudn't try what Matej suggested. I haven't tried the latest xen 4/dom0 using a revision control tool, but I suspect that would be the next logical step. I'd appreciate if you shared your findings on this matter. I have attached my previous post.
-- Mahdavian

Sauro Saltini wrote:
Hi everybody.

I've got a strange problem with PV networking on Linux.

My current configuration is :
- Xen 4.0.0
- DOM0 kernel
- DOMU kernels either or 2.6.36-rc3 (vanilla)

one of my DomU's is intended to act as a router/firewall for all the other ones.

I have configured 2 distinct bridges in Dom0 :
br0 - connects the firewall DomU "external" nic to the external faced host NIC (phisical) br1 - connects the "internal" virtual nic of firewall DomU (eth1) with the other DomU's virtual nics.

Each "guest" DomU has defined the firewall DomU's "internal" address as default gateway, the firewall by now acts simply as a NAT gateway, with ip_forward active and a single NAT rule to SNAT outgoing packets with his own external IP.

I've first installed the fw DomU as an hvm domain (nic's = ioemu) with slackware 13.0 and tried the whole thing connecting from one of the other DomU's to the external network and all worked smoothly.

As soon as I've converted the fw DomU's to a PV domain (using either or 2.6.36-rc3 kernels with PV drivers) something changed in a weird way...

I can still ping the firewall DomU both from "internal" domU's network and from the external lan, but packets from a DomU can't reach the external network anymore !

Running "tcpdump -nvvi" on both firewall's NICs and pinging an external host from one of the other domU's reveals that packets arrive on the firewall, are correctly NATted and appear on the external connected interface, but then simply disappear !

on Dom0 "tcpdump -nvvi br0" (br0 = external bridge) never shows up any traffic !

I've already tried to configure tx checksum offloading = off (ethtool -K <nic> tx off) on all the involved interfaces without any success.

Please help...
Many thanks in advance.

Sauro Saltini.

Xen-users mailing list

This message sent via VFEmail.net
$14.95 Lifetime accounts - 1GB disk, No bandwidth quotas!

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>