This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 4.0.1-rc5 w/ dom0, DomU's start paused

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen 4.0.1-rc5 w/ dom0, DomU's start paused
From: Nicolas Vilz 'niv' <niv@xxxxxxxxxx>
Date: Thu, 05 Aug 2010 15:53:42 +0200
Delivery-date: Thu, 05 Aug 2010 07:08:02 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <i3c2u0$4m5$1@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <i3c2u0$4m5$1@xxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20100713 Thunderbird/3.1.1
On 08/04/10 18:02, ShaunR wrote:
I run my production DomU's using Xen 3.4.1 at the moment with the old
2.6.18.x dom0 kernel. I just built a new Xen version (4.0.1-rc5) with
jemerys git repo of dom0 pvops kernel. When starting domains
the go instantly into a paused state and eventually i see this error on
the command line.

[root@host test1]# xm create -c vps.config
Using config file "./vps.config".
[root@uk1 ndctest1]# Error: Device 0 (vif) could not be connected.
Hotplug scripts not working.

first of all, in this case, the error message pointed me where to look for the error... that and the fact, that without vif-line in xmdomain.cfg the vm boots seemlessly.

If i remove the vif line from the domU config the guest starts up fine.
Anybody know what might be going on?

Yes, I solved your problem.

> My dom0 kernel config --> http://pastebin.com/K8ABm63B

I boiled down your problem to the kernel config. I took a working test system and booted with your kernel, it booted and (suprisingly) my guests paused and crashed after a timeout with the very same error message. So i dug into the hotplug scripts responsible for the networking.

[root@uk1 scripts]# ls -l /etc/xen/scripts/
total 260
-rwxr-xr-x 1 root root 2260 Aug 3 10:37 blktap
-rwxr-xr-x 1 root root 7698 Aug 3 10:37 block
-rw-r--r-- 1 root root 3164 Aug 3 10:37 block-common.sh
-rwxr-xr-x 1 root root 498 Aug 3 10:37 block-enbd
-rwxr-xr-x 1 root root 498 Aug 3 10:37 block-nbd
-rwxr-xr-x 1 root root 2896 Aug 3 10:37 external-device-migrate
-rwxr-xr-x 1 root root 238 Aug 3 13:31 hotplugpath.sh
-rw-r--r-- 1 root root 2065 Aug 3 10:37 locking.sh
-rw-r--r-- 1 root root 804 Aug 3 10:37 logging.sh
-rwxr-xr-x 1 root root 8249 Aug 3 10:37 network-bridge
-rwxr-xr-x 1 root root 2802 Aug 3 10:37 network-nat
-rwxr-xr-x 1 root root 774 Aug 3 10:37 network-route
-rwxr-xr-x 1 root root 840 Aug 3 13:30 qemu-ifup
-rwxr-xr-x 1 root root 842 Aug 3 10:37 vif2
-rwxr-xr-x 1 root root 2661 Aug 3 10:37 vif-bridge
-rw-r--r-- 1 root root 4022 Aug 3 10:37 vif-common.sh
-rwxr-xr-x 1 root root 4859 Aug 3 10:37 vif-nat
-rwxr-xr-x 1 root root 1605 Aug 3 10:37 vif-route
-rwxr-xr-x 1 root root 243 Aug 3 10:37 vscsi
-rwxr-xr-x 1 root root 351 Aug 3 10:37 vtpm
-rw-r--r-- 1 root root 11070 Aug 3 10:37 vtpm-common.sh
-rwxr-xr-x 1 root root 346 Aug 3 10:37 vtpm-delete
-rw-r--r-- 1 root root 1054 Aug 3 10:37 vtpm-hotplug-common.sh
-rw-r--r-- 1 root root 5903 Aug 3 10:37 vtpm-impl
-rw-r--r-- 1 root root 750 Aug 3 10:37 vtpm-migration.sh
-rwxr-xr-x 1 root root 1441 Aug 3 10:37 xen-hotplug-cleanup
-rw-r--r-- 1 root root 2286 Aug 3 10:37 xen-hotplug-common.sh
-rw-r--r-- 1 root root 2414 Aug 3 10:37 xen-network-common.sh
-rw-r--r-- 1 root root 993 Aug 3 10:37 xen-script-common.sh

according to how your xend is configured to setup network (dummy, bridge, nat, routing) and more important, how it is configured to attach the networking for your guests, you need iptables (among other tools). iptables itself relies on some kernel components... you will need state matches, for nat you will need nat table of iptables and masquerading targets and perhaps connection tracking support...

iptables connection tracking and nat support, masqerading, and (finally) the match target was missing in your kernel config. So was the grant table support...

See my modified kernel config http://gist.github.com/509754

I will poke you on IRC this evening.


Xen-users mailing list