This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Reproducible HVM DomU reboot Xen3.2 (Debian Stable)

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Reproducible HVM DomU reboot Xen3.2 (Debian Stable)
From: Adam Goryachev <mailinglists@xxxxxxxxxxxxxxxxxxxxxx>
Date: Thu, 05 Aug 2010 12:09:20 +1000
Delivery-date: Wed, 04 Aug 2010 19:10:31 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20100713 Thunderbird/3.0.6
Hash: SHA1


I've been using xen for a number of years now without issues, but now
have a problem.

First, the problem:
I have a Windows Server 2008 Standard 64bit DomU, I've installed a
number of applications, and it works quite well and runs stable for
weeks at a time so far (ie, has never crashed yet).

I tried to install  QuickBooks Professional
(http://home.quicken.com.au/Pages/ProductDetails.aspx?pcode=25&pcatid=11) or
Enterprise and after agreeing to the terms/etc the DomU reboots (but the
Dom0 and other DomU's continue without error).

After some effort, I found this app is not supported on 64bit Windows
Server 2008. (Though I wouldn't have thought they should be able to
crash windows anyway, as that should be a windows bug...)

Anyway, I had a MS Windows XP Pro SP3 (all latest patches) domu which
has been running fine for over a year with various apps/uses. I decided
to install QuickBooks on this, but got the exact same result (reboot at
the same point during installation).

I'm at a bit of a loss as to what is the issue here, but I can only
assume the fault/problem is with xen, as all other apps/programs work
fine on both windows domu's, all my other linux domu's are working
perfectly, and the apps work fine on non xen based windows machines.

Config (all machines use debian stable (lenny) packages).

File Server: NFS export of all files in use from md RAID1
Xen Dom0:
xen6:/etc/xen# dpkg -l | grep xen
ii  libxenstore3.0                      3.2.1-2
ii  linux-image-2.6.26-2-xen-amd64      2.6.26-24
ii  linux-modules-2.6.26-2-xen-amd64    2.6.26-24
ii  xen-hypervisor-3.2-1-amd64          3.2.1-2
ii  xen-linux-system-2.6.26-2-xen-amd64 2.6.26-24
ii  xen-utils-3.2-1                     3.2.1-2
ii  xen-utils-common                    3.2.0-2
ii  xenstore-utils                      3.2.1-2

xen6:/etc/xen# xm info
host                   : xen6.websitemanagers.com.au
release                : 2.6.26-2-xen-amd64
version                : #1 SMP Sun Jun 20 20:51:58 UTC 2010
machine                : x86_64
nr_cpus                : 6
nr_nodes               : 1
cores_per_socket       : 6
threads_per_core       : 1
cpu_mhz                : 3214
hw_caps                :
total_memory           : 16127
free_memory            : 1043
node_to_cpu            : node0:0-5
xen_major              : 3
xen_minor              : 2
xen_extra              : -1
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32
hvm-3.0-x86_32p hvm-3.0-x86_64
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.3.1 (Debian 4.3.1-2)
cc_compile_by          : waldi
cc_compile_domain      : debian.org
cc_compile_date        : Sat Jun 28 09:32:18 UTC 2008
xend_config_format     : 4

DomU config file:
kernel          = "/usr/lib/xen-default/boot/hvmloader"
builder         = 'hvm'
memory          = 7168
shadow_memory   = 12
device_model    = '/usr/lib/xen-default/bin/qemu-dm'
extra           = "clocksource=jiffies"
name            = "ecstd"
vcpus           = 2

disk = [ 'file:/mnt/wm/windows/ecServer2008STDnormal.img,ioemu:hda,w' ]

vif             = ['mac=00:16:3e:36:24:9c, type=ioemu, bridge=xenbr0']
boot            = 'c'
sdl             = 0
vnc             = 1
vncviewer       = 0
vncconsole      = 0
vncunused       = 1
stdvga          = 0
usb             = 1
usbdevice       = 'tablet'
acpi            = 1
apic            = 1
on_reboot       = 'restart'
on_poweroff     = 'destroy'
on_crash        = 'restart'
audio           = 1
soundhw         = 'sb16'

The hard drive image is NFS mounted from the file server. The xen dom0
is NFS booted from the file server (ie, NFS root), and all other linux
domU's are NFS root from the file server.

I'm at a complete loss as to whether this is even a xen issue, but I
can't think of anything else which could be the problem...

Any other information that is needed I'd be happy to provide... all
assistance gratefully appreciated.


- -- 
Adam Goryachev
Website Managers
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>