This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: Jeremy's GIT-tree and network problems

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Re: Jeremy's GIT-tree and network problems
From: Markus Schuster <ml@xxxxxxxxxxxxxxxxxxxx>
Date: Wed, 30 Dec 2009 00:41:53 +0100
Delivery-date: Tue, 29 Dec 2009 18:01:13 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
Followup-to: gmane.comp.emulators.xen.user
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20091220T1944.GA.ab998.stse@xxxxxxxxxxxxxxxxxxx> <20091220195657.GE16033@xxxxxxxxxxx> <20091221T2246.GA.dbc32.stse@xxxxxxxxxxxxxxxxxxx> <20091222090036.GT16033@xxxxxxxxxxx> <20091222T1448.GA.92265.stse@xxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KNode/4.3.2
Stephan Seitz wrote:
> [..]
>>Sounds like a dom0 networking configuration issue, not a kernel/xen issue.
> I am quite sure this is not the case.
> [..]

Hi Stephan, just found your thread. I think I experience similar issues with 
recent pv_ops dom0 kernels - but I have never tried older versions (like 
2.6.29). I don't want to get into details about the problems I experience  
now - I wanted to start a thread of it's own later on - but could you try to 
lower the MTU of the interfaces that connects dom0 and domU to maybe 1400?
Have you tried pinging an external IP address from dom0? Do you see the 
following message in dom0s dmesg:
[2097720.211014] Attempting to checksum a non-TCP/UDP packet, dropping a 
protocol 1 packet
I see this message for ICMP traffic (and only for ICMP traffic!) between two 
domUs in a setup similar to yours. 
Maybe we suffer from the similar problem?


Xen-users mailing list