This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Unsupported memory accesses after Installing Xen On Ubuntu 8

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Unsupported memory accesses after Installing Xen On Ubuntu 8.04
From: "Peter van Bussel" <info@xxxxxxxxxxxxxxxxx>
Date: Wed, 9 Dec 2009 09:25:39 +0100
Delivery-date: Wed, 09 Dec 2009 00:26:22 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: LandEnergie
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acp4qTC8hsMhiIViQTeDfhNrodSmBQ==
Dear all,

Despite of 

moving /lib/tls to /lib/tls.disabled

I get this warning:

** WARNING: Currently emulating unsupported memory accesses **
** in /lib/tls glibc libraries. The emulation is **
** slow. To ensure full performance you should **
** install a 'xen-friendly' (nosegneg) version of **
** the library, or disable tls support by executing **
** the following as root: **
** mv /lib/tls /lib/tls.disabled **
** Offending process: init (pid=2638) **

I looked at https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/246625

and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/260825

I re-enabled /tls/tls and tried to load xen-friendly library but no luck
(see below). I also tried version 2.6.24-19-xen and changed to hwcap 0
nosegneg but still no luck... Any suggestions?

Regards, Peter 


uname -r

ls /boot
        abi-2.6.24-24-server                    initrd.img-2.6.24-26-xen.bak
        config-2.6.24-19-xen                    lost+found
        config-2.6.24-24-server                 memtest86+.bin
        config-2.6.24-26-xen                    System.map-2.6.24-19-xen
        initrd.img-2.6.24-19-xen                System.map-2.6.24-26-xen
        initrd.img-2.6.24-19-xen.bak            vmlinuz-2.6.24-19-xen
        initrd.img-2.6.24-24-server             vmlinuz-2.6.24-24-server
        initrd.img-2.6.24-24-server.bak         vmlinuz-2.6.24-26-xen
        initrd.img-2.6.24-26-xen                xen-3.2.gz

ldd /sbin/init                                                  
        linux-gate.so.1 =>  (0xf57fe000)
                libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7e55000)
                /lib/ld-linux.so.2 (0xb7fab000)


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Unsupported memory accesses after Installing Xen On Ubuntu 8.04, Peter van Bussel <=