This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Trying to Run OpenSolaris PV

To: Nick Couchman <Nick.Couchman@xxxxxxxxx>, XEN Mailing List <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] Trying to Run OpenSolaris PV
From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
Date: Mon, 7 Dec 2009 11:04:06 -0800 (PST)
Delivery-date: Mon, 07 Dec 2009 11:05:07 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1260212647; bh=O1laD3h4oIyX0sPz/S6xxNHm2C/CXfdoxAZMC9mXslI=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=CoFphrTan4i/ejFNgHSKdRlT+4KWxCI/d4yfMMtXnnz432seSmKMo3RMdVE5401sPORSSFCQ79hUVtKnmJ1t7WU2Ox73cSzMGoF3XqdfGiekIlwOhEJOh/Fw7fxaOjl/IA4JhMa91b9PbnC+nCwVFkr8mXWIgNcrPni/EZOjHp0=
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:References:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=Jy9iWKN/3EGn47sP+6z08NWQ49CcqcO4kAegTh3LsnRmfW7BBcrWJ8iyzPNeC52BEDckA0fOcFstiYkI0FYw1iIWsy2PNj/WUNVejfoiVD9nIxOBP5h4ibqJKRnYqHy/1BNdG9S1JlJNhCE2ggZRyvvjLZOkY2QNrb9dKZEW8XQ=;
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4B1CE2FF0200009900030F65@xxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4B1CC1400200009900030DE9@xxxxxxxxxxxxxxxxxxxxx> <992486.31300.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx> <4B1CE2FF0200009900030F65@xxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
> Still, something is wrong, there - perhaps it's fixed in a later version of Xen
Yes, it is:-

I understood issue. What means "osol ai ISO" ?

Nick Couchman <Nick.Couchman@xxxxxxxxx>
To: XEN Mailing List <xen-users@xxxxxxxxxxxxxxxxxxx>; Boris Derzhavets <bderzhavets@xxxxxxxxx>
Sent: Mon, December 7, 2009 9:11:59 PM
Subject: Re: [Xen-users] Trying to Run OpenSolaris PV

>>> On 2009/12/07 at 11:03, Boris Derzhavets <bderzhavets@xxxxxxxxx> wrote:
> I am not sure regarding libvirt implementation oh SLES10, however
> on Fedoras => 8  John Levon's  suggestion does work:-
> http://blogs.sun.com/levon/entry/opensolaris_2008_11_guest_domain

I'm not using virt-install at all - I'm creating a config file for the domain (see the original post) and trying to start it when I receive the error message.  The kernel and initrd are on my dom0, so ZFS support is irrelevant - I'm not trying to boot using pygrub, virt-install, or anything like that from ZFS.

The issue seems to be the newer 64-bit Opensolaris kernels.  I switched to the 32-bit kernel and it boots just fine - the 64-bit one crashes with the Unhandled page fault.  Not sure why, but this isn't too critical for me right now, as I don't really need anything more than about 1 GB of RAM.  Still, something is wrong, there - perhaps it's fixed in a later version of Xen.

Now I'm running into an issue where the osol disc that I'm trying to boot from won't recognize the install media.  I've tried booting with the following extra= lines in my config file:

extra="/platform/i86xpv/kernel/unix -B console=ttya,livemode=text"
extra="/platform/i86xpv/kernel/unix -B console=ttya,install_media=cdrom"

with no success - the system always fails to find the install media.  In the case of adding install_media=cdrom to list of argument, the Opensolaris media tries to resolve "cdrom" to an http server, which, of course, fails.  I've tried various combinations of disk configurations for the ISO, and none of them seem to work.  I'm using the osol ai ISOs right now, so I'm wondering if there's something in here that doesn't work properly - I'll try switching to the regular ones here as soon as they finish downloading.


This e-mail may contain confidential and privileged material for the sole use of the intended recipient.  If this email is not intended for you, or you are not responsible for the delivery of this message to the intended recipient, please note that this message may contain SEAKR Engineering (SEAKR) Privileged/Proprietary Information.  In such a case, you are strictly prohibited from downloading, photocopying, distributing or otherwise using this message, its contents or attachments in any way.  If you have received this message in error, please notify us immediately by replying to this e-mail and delete the message from your mailbox.  Information contained in this message that does not relate to the business of SEAKR is neither endorsed by nor attributable to SEAKR.

Xen-users mailing list

Xen-users mailing list