This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen Panic w/ dom0 (gentoo-xen-kernel.googlecode

To: Christian Fischer <Christian.Fischer@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] Xen Panic w/ dom0 (gentoo-xen-kernel.googlecode.com patches)
From: Jody Belka <lists-xen@xxxxxxxx>
Date: Wed, 5 Aug 2009 23:51:44 +0100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 05 Aug 2009 15:52:33 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <200908051534.17613.Christian.Fischer@xxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20090804140222.GH3979@xxxxxxxx> <200908051534.17613.Christian.Fischer@xxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.11
On Wed, Aug 05, 2009 at 03:34:17PM +0200, Christian Fischer wrote:
> On Tuesday 04 August 2009, Jody Belka wrote:
> > Hi,
> >
> > I just tried upgrading my dom0 to, using the patches on
> > gentoo-xen-kernel.googlecode.com. It built ok, but trying to boot
> > results in a "FATAL PAGE FAULT" error from xen.
> >
> > Xen specs = Xen 3.4.1-rc2, x84_64
> >
> > Has anyone seen this before, and maybe has an idea what's going wrong,
> > and what I need to do to get a working dom0? I've attached screengrabs
> > of the panic stack/call trace.
> >
> >
> > Jody
> Tried 2.6.30-r2 on HP ProLiant DL380G5 with xen-3.3, panics, no output on vga 
> after relinquishing VGA console, works on Dell Optiplex Core2Duo.
> Switched back to 2.6.29-r4, works out of the box.

Ok, built, with the v6 gentoo-xen-kernel patches, and boots fine.
So I can actually use this system again now :)

Tried upgrading in the first place because of a bug in plain 2.6.29 that
just recently started catching me out, causing endless BUGs from linux.
Since -stable on .29 fixes it as well though, this solution is workable.

I guess the .30 patches just aren't quite there yet, oh well.


Xen-users mailing list