This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] can the root password be recovered from a DomU

To: Xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] can the root password be recovered from a DomU
From: Kevin McKeon <kevin.w.mckeon@xxxxxxxxx>
Date: Fri, 22 May 2009 16:02:00 -0400
Delivery-date: Fri, 22 May 2009 13:03:06 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type; bh=FwZTbauwZ16H+BwhvCi5POhQ7TVilPSuQKvK8UmAgiQ=; b=iuX80fafM2vOg+m5/OYz7OiVV608+h2T+pTqhtYCAMaQ2+L1VxDhMTCUmadhOm1C6o cFmvw6cT7PJ6DQvWDXgnFWJgGn5JRX7V2cj5G/3NJpQDTLBJHRtvrSw+HPayJDrkaZB9 sLsTfW6sT0+fHbs5o4mkeCdYbnyW831NKZR3U=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=UQetqFMOJOI8hhPlC3xfeFPVdt6NDJKcqt+MSWU3cS/25MUSPqLyT06gCXGXN/eb9P yeLX8cK9elon98L2jL0evdrQnfCVIm3XY8eNsdwx2Hdse21bdh/VxILVy2MNSLMkqlsf LdwR3SICb9KPEvX4jh1j78LfGH9F5K469N99Y=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Just curious if anyone knows this. If you loose the root password on a Linux box, you can just boot from CDRom, mount the root partition and edit /etc/shadow.
Is it possible to do something similar with a DomU.

I tried:
mount -o loop mydisk.img /mnt
but I got an error saying something like "you must specify a filesystem type"
mount -o loop -t ext3 mydisk.img /mnt does NOT work either (I've also tried moving the '-t ext3' part but no go)

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>