This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Trouble enabling VT-D: "I/O virtualisation disabled"

To: andrewyates <andrewyates@xxxxxxxxx>
Subject: Re: [Xen-users] Trouble enabling VT-D: "I/O virtualisation disabled"
From: Steve Reaver <stevereaver@xxxxxxxxx>
Date: Tue, 24 Feb 2009 12:05:23 +1100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 23 Feb 2009 17:06:04 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=yU/iI4ZN3a1kNb06kI5AlCaBEPa9s0E0U3Pj71ebIbA=; b=JdVufe8E+X9NdapKVa50Zfoblup3zCPeybPMNIIkcf8xb9QY1hnBrpEqioGgRQvMhc hBEBBRRy7MhKr4Wk7DUBqh4ObzLt7cPW8lJfoky7FueNhSjGDzetWJCEnPgzTGuQk+DU Kqzv0PXYyidwa8EsG4t1ZaBD2hXs5yN16Il0U=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=Wn7GYVGaygEu+TTYb1n1BlKK4u0LUIP4JvAFE0Vj4XiY5G1m1seZ69KlaLexQ8CGsC PAvydB9K3oddidxCAK7kZ65hM+yZSXA+lXs/khd6AC0SctGuwy2WFTqgEgQ+CNTUJPXF JVgQuJd/sDfLGoAzzsQkG7Nsqvq+5cLRxljpA=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <22173121.post@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <22173121.post@xxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I too have the same problems.   Using ASUS P6T and Debian Lenny.  I
played around with it for weeks and just could not get it to work,
here is my original post on the issue.


I've given up for the moment......

On Tue, Feb 24, 2009 at 11:06 AM, andrewyates <andrewyates@xxxxxxxxx> wrote:
> I have a chipset which supports VT-d (Intel X58) and, according to my
> motherboard manufacturers, VT-d is enabled in the BIOS and listed as "Intel
> VT." The problem is that xm dmesg shows "I/O virtualisation disabled" and I
> get this error message when I try to create a domU with a pci device
> assigned: 'Error: failed to assign device: maybe the platform doesn't
> support VT-d, or VT-d isn't enabled properly?".
> I've made sure the PCI device backend driver is compiled into the kernel,
> and dmesg shows pciback seizing my device:
> pciback 0000:03:00.0: seizing device
> pciback 0000:03:00.0: enabling device (0000 -> 0003)
> I also tried it with several other PCI devices. All were seized, but I got
> the same results when trying to launch a domU with any of them. I've tried
> this with both Xen 3.3 and Xen unstable, with the 2.6.26 Debian Xen kernel.
> I can't use an earlier kernel as they don't support my sata chipset.
> Does anyone have any idea what could be causing these errors?
> --
> View this message in context: 
> http://www.nabble.com/Trouble-enabling-VT-D%3A-%22I-O-virtualisation-disabled%22-tp22173121p22173121.html
> Sent from the Xen - User mailing list archive at Nabble.com.
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxxxxxxxx
> http://lists.xensource.com/xen-users

Steve Reaver
Electronic Music Production

Xen-users mailing list