This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Trouble enabling VT-D: "I/O virtualisation disabled"

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Trouble enabling VT-D: "I/O virtualisation disabled"
From: andrewyates <andrewyates@xxxxxxxxx>
Date: Mon, 23 Feb 2009 16:06:33 -0800 (PST)
Delivery-date: Mon, 23 Feb 2009 16:07:16 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I have a chipset which supports VT-d (Intel X58) and, according to my
motherboard manufacturers, VT-d is enabled in the BIOS and listed as "Intel
VT." The problem is that xm dmesg shows "I/O virtualisation disabled" and I
get this error message when I try to create a domU with a pci device
assigned: 'Error: failed to assign device: maybe the platform doesn't
support VT-d, or VT-d isn't enabled properly?".

I've made sure the PCI device backend driver is compiled into the kernel,
and dmesg shows pciback seizing my device:
pciback 0000:03:00.0: seizing device
pciback 0000:03:00.0: enabling device (0000 -> 0003)
I also tried it with several other PCI devices. All were seized, but I got
the same results when trying to launch a domU with any of them. I've tried
this with both Xen 3.3 and Xen unstable, with the 2.6.26 Debian Xen kernel.
I can't use an earlier kernel as they don't support my sata chipset.

Does anyone have any idea what could be causing these errors?
View this message in context: 
Sent from the Xen - User mailing list archive at Nabble.com.

Xen-users mailing list