This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] howto bring a soundcard into a domU

From: "Todd Deshane"
On Mon, Dec 22, 2008 at 2:00 AM, Daniel Bauer <mlist@xxxxxxxxxxx> wrote:
From: "Todd Deshane"

On Sun, Dec 21, 2008 at 7:11 AM, Daniel Bauer <mlist@xxxxxxxxxxx> wrote:

Hi @all,

I have many domU on my server and they work fine, some of them have their
own NICs with the PCI param in the config.

Now I try to bring a soundcard for asterisk into a new domU and have the
following trouble:

rz3-ta:~ # lspci
00:00.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)

PCI: Enabling device 0000:00:00.0 (0000 -> 0001)
EMU10K1_Audigy: probe of 0000:00:00.0 failed with error -12

I don't find a solution howto get the card working. In dom0 it works

Have anybody a hint for me?

Have you tried pci.permissive on the kernel command line? (equivalent
to an option to loading the pciback module)

I don't know which options to try :(

In your grub configuration do you have the pciback.hide option there?

no, I tried this with the NICs, but it doesn't work, so I do it manually ...

Or do you give the device over to pciback manually?
echo -n 0000:0f:01.0 > /sys/bus/pci/drivers/EMU10K1_Audigy/unbind
echo -n 0000:0f:01.0 > /sys/bus/pci/drivers/pciback/new_slot
echo -n 0000:0f:01.0 > /sys/bus/pci/drivers/pciback/bind

At the point of passing it over, either with grub or manually, you
should have the chance to pass pciback.permissive

I don't know pciback.permissive, the soundcard is detected by alsa, but it stops working with the mentioned error message in domU

Other than that, could it be the driver not working properly in the

dom0 and domU are the same

The kernel and ramdisk are the same?

I think so, it's a openSUSE Standard install.

Is the module loading in the guest properly?

in the dom0 yes, in the domU not, the error ist
EMU10K1_Audigy: probe of 0000:00:00.0 failed with error -12


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>