This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Problem with Windows 2003 domU's

To: Russell Foster <rghf@xxxxxxxxxx>
Subject: Re: [Xen-users] Problem with Windows 2003 domU's
From: Ken Cobler <kcobler@xxxxxxxxxxxxxx>
Date: Fri, 12 Dec 2008 08:06:39 -0600
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Fri, 12 Dec 2008 06:07:25 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4940FF10.5050406@xxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4940FF10.5050406@xxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20081105)
Russell Foster wrote:
I was building a template for deploying Windows 2003 and all was working fine however I've hit an issue where trying to start Windows 2003 domU's isn't working and I'm ending up with

[root@LSN-D2066 ~]# xm list
Name ID Mem(MiB) VCPUs State Time(s) Domain-0 0 2442 4 r----- 23.7 newwintemplate.vm 4 511 1 ------ 0.0 vladawin.vm 5 511 1 ------ 0.0 wintemplate.vm 6 511 1 ------ 0.0

Where the time stays at 0.0. It was working fine and something obviously changed but I don't know what.

When starting the domU the interface is being added to the bridge device as I first thought it was a networking issue as tunctl wasn't installed

[root@LSN-D2066 ~]# brctl show
bridge name    bridge id        STP enabled    interfaces
xenbr1        8000.feffffffffff    no        vifwint01

If I start a Linux based domU that works fine on the same machine so I thought it was something to do with qemu but I can't see any errors in the logs.

I reset the xenstore via

rm /var/lib/xenstored/tdb

but still no go. I'm now pretty much out of ideas and would like some guidance on where to look / relevant logs snippits I can post



When I built Xen 3.3 from source, I had a similar problem getting Windows 2003 to start. My Windows 2003 HVM worked fine on Xen 3.0, but, not 3.3.

I did not build the hvmloader tool when originally building Xen 3.3. Once I built hvmloader and used the correct hvmloader in my vm config file, Windows 2003 booted normally on Xen.

Ken Cobler

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>