This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] The old booting problem partially solved

To: Mats.Petersson@xxxxxxx
Subject: [Xen-users] The old booting problem partially solved
From: "Octavian Teodorescu" <octav@xxxxxxxxxxxxxxxx>
Date: Thu, 31 May 2007 00:03:20 +0300 (EEST)
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 30 May 2007 14:00:08 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: SquirrelMail/1.4.8-4.el4.centos
So, I thought that maybe there is something more deeper into CentOS xen
kernel which causes the problem and I have installed a Fedora Core 5
Configured again ns1:
kernel = "/boot/vmlinuz-2.6.20-1.2316.fc5xenU"
ramdisk = "/boot/initrd-2.6.20-1.2316.fc5xenU.img"

memory = 384
name = "ns1"
vcpus = 1

vif = [ 'mac=00:00:01:02:03:04 , ip=xx.xxx.xxx.xxx, bridge=xenbr0' ]
#vif = [ '', 'bridge=xenbr1' ]
disk = [ 'phy:vg/root.ns1,sda1,w',
         'phy:vg/swap.ns1,sda2,w' ]


# Set root device.
root = "/dev/sda1 ro"
Started and I also received an error but this time more understandable :) .
This is the last part of the boot messages from guest os (also fedora core
5 base):
INIT: version 2.86 booting
                Welcome to Fedora Core
                Press 'I' to enter interactive startup.
modprobe: FATAL: Could not load
/lib/modules/2.6.20-1.2316.fc5xenU/modules.dep: No such file or directory

Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
Setting clock : Wed May 30 16:18:50 EDT 2007 [  OK  ]
Starting udev: [  OK  ]
Setting hostname localhost:  [  OK  ]
Checking filesystems
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
Checking all file systems.
[/sbin/fsck.ext3 (1) -- /dev/vg/ns1] fsck.ext3 -a LABEL=/
/proc/misc: No entry for device-mapper found
Is device-mapper driver missing from kernel?
Failure to communicate with kernel device-mapper driver.
fsck.ext3: Unable to resolve 'LABEL=/'
I have some questions:
- I have created a directory under / called vhosts were I intend to mount
the partitions of the guest systems. How does xen know were to mount those
partitions (in this case /vhosts/ns1)? I mean, were should I set this, or
this is just mounting when the system is off for debugging purposes?
Should I mount the partition root.ns1 and then edit the fstab located
there (which I have allready edited, but it seems that I have made a
mistake) ?

fstab of root.ns1:
LABEL=/                 /dev/vg/ns1             ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
swap                    /dev/vg/swap.ns1        swap    defaults        0 0

- second question, I know that I have mistaken around here somewhere. Can
somebody enlighten me please?
- what about the kernel-xenU modules error any idea how can I fix that,
since in /lib/modules/2.6.20-1.2316.fc5xenU folder there is modules.dep ?

I've solved a couple of this problems (copied from dom0 the modules to
root.ns1; and modified fstab in root.ns1) but I didn't deleted them in
case the info is good for solving the following problem:

although I have set up vif= [....] in the config of the guest when I run
ifconfig -a it sees only the loopback network card. Any idea why? Is it a
operating system problem? or a xen problem?


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] The old booting problem partially solved, Octavian Teodorescu <=