This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] Make error

To: "Petersson, Mats" <Mats.Petersson@xxxxxxx>, "James Harper" <james.harper@xxxxxxxxxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] Make error
From: "Ian Tobin" <itobin@xxxxxxxxxxxxx>
Date: Wed, 23 May 2007 13:14:02 +0100
Delivery-date: Wed, 23 May 2007 05:16:42 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Aceb4sl2hx3W0EJTTHuVaymciS3ylAAdqd1AAAG7E70AABqsQAAAw0JQAABYglAAAOt7pwAAETMAADKsCXc=
Thread-topic: [Xen-users] Make error
getting another problem now.
I can now use menuconfig and select the bits to install.
I then issue command make which takes a while but completes.  I then issue make install which also completes
I then
make install
goes quite a way through then brings up this error
if [ -r System.map -a -x /sbin/depmod ]; then /sbin/depmod -ae -F System.map -b / -r 2.6.18-xen; fi
make[3]: Leaving directory `/usr/src/xen-3.1.0-src/build-linux-2.6.18-xen_x86_32'
make -C build-linux-2.6.18-xen_x86_32 ARCH=i386 INSTALL_PATH=/ vmlinuz
make[3]: Entering directory `/usr/src/xen-3.1.0-src/build-linux-2.6.18-xen_x86_32'
make -C /usr/src/xen-3.1.0-src/linux-2.6.18-xen O=/usr/src/xen-3.1.0-src/build-linux-2.6.18-xen_x86_32 vmlinuz
  Using /usr/src/xen-3.1.0-src/linux-2.6.18-xen as source for kernel
  /usr/src/xen-3.1.0-src/linux-2.6.18-xen is not clean, please run 'make mrproper'
  in the '/usr/src/xen-3.1.0-src/linux-2.6.18-xen' directory.
make[5]: *** [prepare3] Error 1
make[4]: *** [vmlinuz] Error 2
make[3]: *** [vmlinuz] Error 2
make[3]: Leaving directory `/usr/src/xen-3.1.0-src/build-linux-2.6.18-xen_x86_32'
make[2]: *** [build] Error 2
make[2]: Leaving directory `/usr/src/xen-3.1.0-src'
make[1]: *** [linux-2.6-xen-install] Error 2
make[1]: Leaving directory `/usr/src/xen-3.1.0-src'
make: *** [install-kernels] Error 1
ictsrv:/usr/src/xen-3.1.0-src# cd linux-2.6.18-xen
ictsrv:/usr/src/xen-3.1.0-src/linux-2.6.18-xen# make mrproper
  CLEAN   scripts/basic
  CLEAN   scripts/kconfig
  CLEAN   include/config
  CLEAN   .config
Ive tried everything i can think of
make clean
make clean install
make mrproper
deleted all 3.1 files out from /boot
even removed the whole source directory and  started again, still no joy.  Any ideas?

From: Petersson, Mats [mailto:Mats.Petersson@xxxxxxx]
Sent: Tue 22/05/2007 13:06
To: Ian Tobin; James Harper; xen-users@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-users] Make error

> -----Original Message-----
> From: Ian Tobin [mailto:itobin@xxxxxxxxxxxxx]
> Sent: 22 May 2007 13:01
> To: Petersson, Mats; James Harper; xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: RE: [Xen-users] Make error
> yes your correct, it was set to PC-compatable, i have changed
> that to XEN and it is now compiling.

> not sure how you figured that out but thanks :)

I just went through the "obvious" steps of "trying to build just the
kernel", which meant "make menuconfig" on a "clean" Linux-2.6.18, which
in turn meant that the config file isn't set up for Xen (I noticed that
it wasn't before I tested it, so I just guessed that was the problem -
which I then proved by changing it and, as you say, it compiles).

The reason it fails is that the patches that Xen apply modifies some
things. In this case, a macro that would in native mode compile nicely,
but now turns into something that can't be used in asm-offsets in Xen.


> ________________________________
> From: Petersson, Mats [mailto:Mats.Petersson@xxxxxxx]
> Sent: Tue 22/05/2007 12:45
> To: James Harper; Ian Tobin; xen-users@xxxxxxxxxxxxxxxxxxx
> Subject: RE: [Xen-users] Make error
> > -----Original Message-----
> > From: James Harper [mailto:james.harper@xxxxxxxxxxxxxxxx]
> > Sent: 22 May 2007 12:30
> > To: Petersson, Mats; Ian Tobin; xen-users@xxxxxxxxxxxxxxxxxxx
> > Subject: RE: [Xen-users] Make error
> >
> > > > -----Original Message-----
> > > > From: Ian Tobin [mailto:itobin@xxxxxxxxxxxxx]
> > > > Sent: 22 May 2007 12:00
> > > > To: Petersson, Mats; xen-users@xxxxxxxxxxxxxxxxxxx
> > > > Subject: RE: [Xen-users] Make error
> > > >
> > > > thanks Matts, just so you know this is  a Dell PE1750 2.4 Xeon.
> > >
> > > And that will make what difference? It should still build.
> > >
> >
> > It could make the world of difference... aren't there a few
> different
> > flavours that come under the i386 architecture? Certainly I
> > don't think
> > you'd reproduce a problem from arch/i386 on a powerpc or amd64.
> What MACHINE it is won't make much of a difference (afaik
> Linux doesn't
> have any logic to figure out what the hardware looks like much beyond
> figuring which model and mode of processor it is being run on). The
> architecture being built for is a different matter.
> >
> > A copy of the .config is probably required to reproduce the problem
> > though... as well as the version of gcc etc in use.
> Possibly, but I've just repro'd the problem (although, as you say,
> x86_64 build doesn't have the same problem!)
> And I believe I know what the problem is too: The
> subarchitecture in the
> config isn't set to "Xen" but "PC-compatible".
> --
> Mats
> >
> > James

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>