This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] help with xen instalolation on debian ecth

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] help with xen instalolation on debian ecth
From: Michele Menciassi <michele@xxxxxxxxxxxxxx>
Date: Tue, 08 May 2007 15:55:39 +0200
Delivery-date: Tue, 08 May 2007 06:51:22 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200705081345.14413.ibc@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4640516B.4080809@xxxxxxxxxxxxxx> <200705081345.14413.ibc@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20070418)
Iñaki Baz Castillo ha scritto:
El Tuesday 08 May 2007 13:37:30 escribió:
Thank for your answer i've tried to set a static mac address for my DomU...
but i have the same problem to use network into DomU.

i put

vif  = [ 'ip=, mac=00:16:00:00:00:01' ]
into my DomU config file

I'm not sure that the MAC you have put it allowed in Xen.
Try with 00:16:3e:60:73:3d instead and probe again.
i'll tried with the mac you sudgest and other
in this document http://wiki.xensource.com/xenwiki/XenNetworking
it's explained that mac can assume that value:
where X is any hexadecimal digit, and Y is one of 2, 6, A or E. 

but DomU network still don't work
i restarted my server... but...
now when i enter in DomU console (xm console myDomUname)

i've the follow message:

netfront:device eth0 has flipping receive path

Humm, not idea about it :(
but similar errors appear in Google, try it ;)
i've just see on google about that error
in this document there is an answer
but i don't understand what exactly i must do to fix it
the document say:
> I'm running 3.0.3 on on debian amd64 on a dual core Opteron 265.
> In a  debian amd64 domU I see these messages:
> netfront: device eth0 has flipping receive path.
> I noticed ssh connections to my domU are dropped quite frequently.
> But I am not sure if this is related.
> Can anyone shed any light on the meaning of the above error?

It's not an error, just an informational statement.

If you want to try the 'copying receive path', place 'xennet.rx_copy' on
your domU kernel command line.

 -- Keir

What meaning exactly?
'copying receive path', place 'xennet.rx_copy' on
your domU kernel command line
i see that at boot of DomU there is a fatal error...
modules /lib/modules/2.6.18-4-xen-vserver-amd64
isn't founded at boot
how can i solve that problem?
if i do the following:

# cat /proc/net/dev
i see that i've
lo and eth0 too

but if i do
# ifconfig
i see only lo and no other interface

What does occur if you do in domU:

# ifconfig eth0 netmask
if i do that... ifconfig show eth0 interface...
but i can't use the network... ping don't work... apt don't work...

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>