This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Centos + Xen 3.0 + Root on md = bad

To: larsks.21230602@xxxxxxxxxxxxx
Subject: Re: [Xen-users] Centos + Xen 3.0 + Root on md = bad
From: Steven Ellis <mail_lists@xxxxxxxxxxxxxxxx>
Date: Thu, 15 Dec 2005 17:25:24 +1300
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Thu, 15 Dec 2005 04:27:46 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1134573204.2310814296.31478.sendItem@xxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <1134573204.2310814296.31478.sendItem@xxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird 1.5 (X11/20051127)
larsks.21230602@xxxxxxxxxxxxx wrote:
>> I had the same problem. Fixed it with compiling the RAID modules
>> in (CONFIG_MD_*).
> Taneli,
> Thanks for the information.
> That gives me two other questions:
> (1) This is for the folks at Xensource responsible for the binary distribution
> -- if md support under Xen requires the md drivers to be compiled into the
> kernel, why does the binary distribution from Xensource have them built as
> modules?
> (2) I've tried adding mdadm to the initrd, and it complains that
> /dev/md0 and /dev/md1 don't exist.  In fact, they *do* exist on the initrd
> filesystem *prior* to starting udev; after udev starts I'm not positive 
> (didn't
> have much time to fiddle with it this morning).  Even running mdadm with 
> --auto=yes
> fails to create the device nodes.  *Should* this work?  Or is it simply not
> possible to use the md drivers built as modules under the Xen kernel?
I've been running Centos 4.x with Xen 2.0.7 and md raid1 based root
partitions for a while now. A couple of tips.

1. Double check that the Xen supplied kernel has all of the other
modules you need. It was missing the modules for the extra PCI IDE cards
I use.

2. Make your own initrd using the supplied mkinitrd command. It should
sort out all of the module and raid issues. Couldn't ever boot with the
Xen supplied initrd files if I had raid partitions.

I'll be interested to hear how you go as I haven't upgraded my Xen 2.0.7
environment yet as for the moment it is quite stable and I don't want
the downtime. Perhaps in the new year.


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>