This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Centos + Xen 3.0 + Root on md = bad

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Centos + Xen 3.0 + Root on md = bad
From: larsks.21230602@xxxxxxxxxxxxx
Date: 14 Dec 2005 15:13:24 -0000
Delivery-date: Wed, 14 Dec 2005 15:15:36 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
> I had the same problem. Fixed it with compiling the RAID modules

> in (CONFIG_MD_*).


Thanks for the information.

That gives me two other questions:

(1) This is for the folks at Xensource responsible for the binary distribution
-- if md support under Xen requires the md drivers to be compiled into the
kernel, why does the binary distribution from Xensource have them built as

(2) I've tried adding mdadm to the initrd, and it complains that
/dev/md0 and /dev/md1 don't exist.  In fact, they *do* exist on the initrd
filesystem *prior* to starting udev; after udev starts I'm not positive (didn't
have much time to fiddle with it this morning).  Even running mdadm with 
fails to create the device nodes.  *Should* this work?  Or is it simply not
possible to use the md drivers built as modules under the Xen kernel?


  -- Lars

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>