This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 3.0.0 + RAID + LVM + CentOS = problem / SOLVED


Got Xen 3 to work. I was booting the wrong kernel which didn't have
the raid modules compiled in, so when I switched to the compiled-in
version, Xen booted up just fine. So there's something wrong with
either the modules themselves or the initrd.

Taneli Leppä wrote:
Vincent Hanquez wrote:
are you able to mount single partition from the raid array on the demo cd ?
like mounting just sda1 *or* sdb1 ?
and if yes, are you able to read what's on the partition correctly ?

I tried the demo CD. It doesn't autodetect/autorun anything, but I was
able to get both RAID1 and LVM running by installing the necessary
packages with apt-get. So they do work.

Maybe this has specifically something to do with the raid autorun
functionality, since it breaks when upgrading to the Xen dom0 kernel?

  Taneli Leppä         | Crasman Co Ltd
  <taneli@xxxxxxxxxx>  | <http://www.crasman.fi/>

Xen-users mailing list