This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Xen 3.0.0 + RAID + LVM + CentOS = problem

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Xen 3.0.0 + RAID + LVM + CentOS = problem
From: Taneli Leppä <taneli@xxxxxxxxxx>
Date: Fri, 09 Dec 2005 10:32:00 +0200
Delivery-date: Fri, 09 Dec 2005 08:31:07 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: Crasman Co Ltd
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird 1.6a1 (Windows/20051206)

I installed CentOS 4.2 (RHEL4 based) on a server (P4 3.4, 4GB mem,
2 x 250GB SATA-drives). I've tried both official Xensource RPMs and
the CentOS RPMs posted by Aaron Weller, but I can't get neither to
work. I'm running LVM on top of software RAID1 (autostarted) and
it works fine on regular CentOS kernel, but the Xen dom0 kernel
doesn't boot. I get:

Loading dm-mod.ko module
device-mapper: 4.4.0-ioctl (2005-01-12) initialized
Loading md.ko module
md: md driver 0.98.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
Loading raid1.ko module
md: raid1 personality registered as nr 3
Loading jbd.ko module
Loading ext3.ko module
Loading dm-mirror.ko module
Loading dm-zero.ko module
Loading dm-snapshot.ko module
raidautorun: RAID_AUTORUN failed: 19
raidautorun: RAID_AUTORUN failed: 19
Making device-mapper control mode
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  No volume groups found
Activating logical volumes
  Unable to find volume group "Storage"
ERROR: /bin/lvm exited abnormally! (pid 892)
Creating root device
Creating root filesystem
mount: error 6 mounting ext3
mount: error 2 mounting none
Switching to new root
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

And here it ends. The disks are detected fine under Xen as well,
so the problem seems to be RAID autorun. I found a post on some
mailinglist that advised to compile the RAID modules into the
kernel. I tried that but with the same results. I haven't tried
Xen 2.0 yet on this box, but I have another box with similar setup
(LVM on RAID1) with Xen 2.0 which works fine.

Any clues?

  Taneli Leppä         | Crasman Co Ltd
  <taneli@xxxxxxxxxx>  | <http://www.crasman.fi/>

Xen-users mailing list