This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] max_loop device problem

> title Xen-2.6
>   root (hd0,0)
>   kernel /xen.gz dom0_mem=65536
>   module /vmlinuz- root=/dev/hda6 ro console=tty0
> max_loop=256

That looks OK but I guess 256 might be too high.  IIRC, the loop driver 
handles a maximum of 100 devices, or so.  Try reducing it to something like 
32, 64, etc and see if that helps.

You have compiled loop support statically into the kernel, right?  If it's in 
a module, you'll need to pass it as a module parameter instead.

> brw-r--r--    1 root     root       7,   9 Jun 25 21:00 /dev/loop9

Why does this one have different permissions to the other ones?  (not that it 
should matter, but all the same...)

> I created a sparse filesystem and tried to mount that on loop back device
> [root@guava looptest]# mount -o loop  root_fs loop1/
> mount: could not find any free loop device


> [root@guava looptest]# mount -o loop=/dev/loop9  root_fs loop1/
> ioctl: LOOP_SET_FD: Device or resource busy

Sanity check: Have you tried loop10, etc...?  Do they all give this error?

> haunting this machine... I need a quick a reply since we are using xen
> in a production environment...

If the above don't help, can you rebuild the kernel and statically configure a 
higher number of loop devs (say, 32), then reboot dom0?


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>