This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] missing drivers, am I confused?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] missing drivers, am I confused?
From: Sascha Retzki <sretzki@xxxxxx>
Date: Sat, 25 Jun 2005 16:48:21 +0200
Delivery-date: Sat, 25 Jun 2005 14:49:08 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <200506251442.06600.mark.williamson@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Mail-followup-to: xen-users@xxxxxxxxxxxxxxxxxxx
References: <20050625134407.GC26904@MEniac> <200506251442.06600.mark.williamson@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.4.2i
On Sat, Jun 25, 2005 at 02:42:06PM +0100, Mark Williamson wrote:
> > Ehm, I tried my luck with a 2.6.11 (that which ships with xen-2.0.6)
> > and tried to find my NICs, soundcard and so on under
> > make ARCH=xen menuconfig
> > but, I can't. I am seriously confused, why is that?
> Unless you enable Physical Device Access in the Xen section of the config, 
> the 
> Drivers section of the kernel config won't be very interesting ;-)  I seem to 
> remember these defaulting to off...  Anyhow - if you enable that, and 
> Privileged Domain then it should work.
> You might need to also go switch on "PCI Bus Support" somewhere.

Ough what a hell :-) . So why is so much stuff disabled? I mean, 
if I make menuconfig without setting ARCH, it is assumed that my machine
has a PCI-bus, but with Xen, it is not?

However thanks for the pointer, it still fails (probably because other
important yet configureable stuff have been disabled, too) but I have
something to look for ;-)

> Cheers,
> Mark

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>