This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] No video display, SuSE kernel-xen-

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] No video display, SuSE kernel-xen-
From: Robbie Dinn <robbie@xxxxxxxxxxxx>
Date: Mon, 13 Jun 2005 21:12:19 +0100
Delivery-date: Mon, 13 Jun 2005 20:11:28 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <A95E2296287EAD4EB592B5DEEFCE0E9D2821E1@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <A95E2296287EAD4EB592B5DEEFCE0E9D2821E1@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)
Hello Ian

Ian Pratt wrote:
This is a strange one. On upgraging to SuSE kernel-, I have suddenly found that I loose the video on boot up! The video disappears very early in boot, possibly while Xen hypervisor is starting, printing out the physical memory map.

I have also tried a xen-2.0-testing that I compiled myself (with the rev 1.1899 "Ensure we only handle writable pagetable faults taken in guest kernel") Same outcome

Odd. Please can you try the kernel that shipped with Xen 2.0.5 to see if
we can narrow down when the issue was introduced.

I have down loaded various sources and binaries from both
www.cl.cam.ac.uk and from www.suse.de/~garloff/linux/xen/ .
I will try various combinations of these tonight.

Are you sure you haven't got any vga related settings in your grub
config that may have changed?

I don't remember making any changes to the grub config, other than
specifying different xen image or dom0 kernels or dom0 root images.

Specifically I don't have a linux kernel vga=whatever command line
parameter. I believe I have been using the ordinary VGA text mode
console, not a vesa framebuffer and not one of the vga chipset
specific framebuffer drivers either ( at least not intensionally).

Part of the reason I don't use the VESA frame buffer is that I can
never remember numbers for the modes.

> What graphics card do you have?
Ah, well we are a hardware manufacturer, so we have quite a few
different types! I have to beg from from the other engineers to get
access to them though.

I have just been looking through the xen documentation to what
other command line parameters there are for xen and linux.

xen's console=
I don't have this set currently. The default looks sensible,
but maybe I should try one of the other settings?

linux's console=
I tried console=tty0 at David Barrera's suggestion, no joy though.

linux's xencons=
I am not sure I understand from the description what this does
or if it is of interest.

Robbie Dinn

Xen-users mailing list