This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] CONFIG_XEN_PHYSDEV_ACCESS in domainU

To: Patrice <patrice-xen@xxxxxxxxxx>
Subject: Re: [Xen-users] CONFIG_XEN_PHYSDEV_ACCESS in domainU
From: David Muench <davemuench@xxxxxxxxx>
Date: Sat, 11 Jun 2005 22:14:28 -0400
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 12 Jun 2005 02:13:38 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=NimWkYxzqBGZrRPpIhzCH9qDdvrx4Kai1DgK2foueOssJi/sB2ZjAr7sZOslqZQyQ5ogb4NeZatmfxtE2+AK8QWGkcXDUNyRWCxn+0AKDl0/oXzGrKRXGbn7iQTMK66/F0yKzAjuNxCuLHGAerU6YxFVl8hzNmBlySxUodKymBg=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <000301c56d41$09721360$c237a8c0@xxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <000301c56d41$09721360$c237a8c0@xxxxxxxxxxxxxxxxxx>
Reply-to: David Muench <davemuench@xxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I think I ran into a similar problem. I had to also enable the domain
0 config option to get the kernel to work at all. I'm not sure if
that's expected or if this is a bug as I'm relatively new to Xen.

Once I did that however, my PCI cards worked great in a domU.


On 6/9/05, Patrice <patrice-xen@xxxxxxxxxx> wrote:
> Hi,
> We have been using Xen for several months now and it works real great (we
> have it running on Intel SR1300, Intel SR2300 and PowerEdge 1850).
> Now we need one unpriviledged host to be able to access directly 2 PCI cards
> (RocketPort and modem on PowerEdge 1850):
> As soon as I set CONFIG_XEN_PHYSDEV_ACCESS=y for a domainU, I can no longer
> start the virtual host, there is nothing on the console but I get the
> following from the xend log:

David Muench - davemuench@xxxxxxxxx
Jabber ID: dave@xxxxxxxxxxxxxxxxxxxx

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>