This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] No networkcard with Xen2.0.6 (3C940)

To: gpolooo@xxxxxxxxx, xen users list <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] No networkcard with Xen2.0.6 (3C940)
From: "opensource@xxxxxx" <opensource@xxxxxx>
Date: Wed, 01 Jun 2005 13:05:28 +0200
Delivery-date: Wed, 01 Jun 2005 11:03:40 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1117553847.7127.5.camel@xxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <429C3708.1020803@xxxxxx> <1117553847.7127.5.camel@xxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 1.0.2 (X11/20050317)
Hi again,

my problem is nearly solved.
As I described I saw the driver beeing compiled (yes it was sk98lin) but
was wondering why I have no eth0 while booting xen0.
ifconfig showed only the lo device.

An ifconfig eth0 up solved the problem
and I could configure my card.

But I have to run ifconfig everytime I restart my xen0 System.
Don't get me wrong I have prevously configured my eth0 Card before
installing xen.
So what am I doing wrong here.
Am I missing something?

Kind Regards
Dennis Erlach

>I use this same network and when I was using xen stable there was no
>problem with it. But I would say what is going on is this: when you run
>make world, it cleans your kernel tree and everything else that was
>compiled before in your xen dir, so it erases your .config that had this
>module (or bultin). After you change options for xen0 kernel, do make
>dist or make kbuild at xen main dir, then install with ./install.sh or
>make install. If you are really sure it compiled within the xen0 kernel
>(I doubt this if you ran make world) try loading (module: sk98lin).
>On Tue, 2005-05-31 at 12:06 +0200, opensource@xxxxxx wrote:
>>Hi List,
>>I have an installtion of Ubuntu 5.04 and try to get Xen running.
>>Xen boots fine except that an ifconfig tells me only the loopback device
>>is present.
>>I think the driver for my OnBoard Networkcard 3C940 is not built in.
>>Can anyone tell me how to solve this issue?
>>I have tried to compile form source which has the same result.
>>I tried to prepare the Kernel for me like the Documentation told me:
>>" make ARCH=xen xconfig "
>>I selected the Yukon Marvel Driver which supports the 3C940 Card.
>>a " cd .. " and " make " gives me the output that there is no rule for make.
>>I also edited the defconfig file for xen0. make world compiles fine. I
>>see the driver during compiling.
>>But still the same issue.
>>Please anyone help me.
>>Kind Regards
>>Dennis Erlach
>>Xen-users mailing list
>Xen-users mailing list

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>