This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Help booting Xen under RHEL6 beta2

To: Ian Campbell <Ian.Campbell@xxxxxxxxxx>, Stefano Stabellini <stefano.stabellini@xxxxxxxxxxxxx>
Subject: RE: [Xen-devel] Help booting Xen under RHEL6 beta2
From: Dan Magenheimer <dan.magenheimer@xxxxxxxxxx>
Date: Mon, 12 Jul 2010 13:19:29 -0700 (PDT)
Cc: Young <m.a.young@xxxxxxxxxxxx>, xen-devel@xxxxxxxxxxxxxxxxxxx, DonDutile <ddutile@xxxxxxxxxx>, Konrad Wilk <konrad.wilk@xxxxxxxxxx>
Delivery-date: Mon, 12 Jul 2010 13:23:05 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <1278945437.24714.171.camel@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <1e22d374-43a0-4fe9-bea4-65511d0e0430@default> <4C372DA1.4020701@xxxxxxxxxx> <20100709174438.GA10615@xxxxxxxxxxxxxxxxxxx> <alpine.LFD.2.00.1007091905190.31708@xxxxxxxxxxxxxxx> <20100709200100.GB16035@xxxxxxxxxxxxxxxxxxx> <8484230b-92f7-4a53-8972-47f4f52071ba@default> <alpine.LFD.2.00.1007100015130.19968@xxxxxxxxxxxxxxx> <e637f372-3f1f-45b3-91af-117debd4dbde@default> <530185ed-c8b1-4ace-ab3f-f237e62b33d3@default> <alpine.DEB.2.00.1007121137030.21432@kaball-desktop> <34971627-0927-4A9B-8187-A42C6D6784A6@xxxxxxxxxx> <alpine.DEB.2.00.1007121506160.21432@kaball-desktop 1278945437.24714.171.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
OK, so here's another interesting piece of information:

The xend.log python error trace ends with:

  xs_handle = xen.lowlevel.xs.xs()
Error: (111, 'Connection refused')

So I rebooted (with xend disabled), manually started xenstored,
and ensured xenstored is indeed running with ps -ef.
Then I tried "xenstore-ls" and all I get is:

tool = ""
 xenstored = ""
local = ""

I tried this on a EL5-based distro running a
dom0 (with xend disabled on boot) and xenstore-ls gives
me a long list of dom0 related registry entries.

So maybe xenstored is dependent on some distro configuration
that is missing on RHEL6b2?


P.S. I checked /dev/xen and it does contain evtchn and gntdev
and my kernel config does have CONFIG_XEN_DEV_EVTCHN=y

> -----Original Message-----
> From: Ian Campbell [mailto:Ian.Campbell@xxxxxxxxxx]
> Sent: Monday, July 12, 2010 8:37 AM
> To: Stefano Stabellini
> Cc: Dan Magenheimer; xen-devel@xxxxxxxxxxxxxxxxxxx; Konrad Rzeszutek
> Wilk; DonDutile; Young
> Subject: Re: [Xen-devel] Help booting Xen under RHEL6 beta2
> On Mon, 2010-07-12 at 15:06 +0100, Stefano Stabellini wrote:
> > On Mon, 12 Jul 2010, Dan M @ Oracle wrote:
> > > Is xencommons in 4.0-testing?  If so, where?
> >
> > in the sources:
> >
> > tools/hotplug/Linux/init.d/xencommons
> >
> > it should be installed in /etc/init.d
> That change is only in xen-unstable, isn't it? In xen-4.0-testing it
> looks to me like tools/misc/xend still takes care of it so if you've
> switched to xl in that branch you might still need to start stuff by
> hand.
> Ian.

Xen-devel mailing list