This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH] xm --version

To: Ian Pratt <m+Ian.Pratt@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] [PATCH] xm --version
From: aq <aquynh@xxxxxxxxx>
Date: Thu, 9 Jun 2005 17:57:57 +0900
Cc: Xen Dev <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 09 Jun 2005 08:57:07 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=tvfliOuAalUJhCJd7A2dKSiS9I6OOM2YE04Mi1rVkXa4Y03tZhlP0Y6VtTHv1wIcdXnSc1F8HUrhe+MRXGu1QPnxQ5jwFIRSzu/TiJUpvf+ba+MFJoCox2L1ep4nfCZnTSIrwd5VSs8b1+gHnuNPGsAycO5MV74tIqo7199XgZw=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <A95E2296287EAD4EB592B5DEEFCE0E9D282144@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <A95E2296287EAD4EB592B5DEEFCE0E9D282144@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Reply-to: aq <aquynh@xxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On 6/9/05, Ian Pratt <m+Ian.Pratt@xxxxxxxxxxxx> wrote:
> > can you confirm that ht_per_core is also wrongly set? it is
> > set (=1) at arch/x86/setup.c or arch/ia64/smpboot.c, but
> > never changed. but this variable is used somewhere, and got
> > reported in "xm info", for example.
> >
> > so all of its usage are also wrong when we use HT? (because
> > in that case ht_per_core must be 2)
> OK, that's bad -- the code that initialised ht_per_core has also gone.
> What we need to do is to take the new code from Linux 2.6.12-rc5 that
> understands multicore, and correctly initialise ht_per_core and
> core_per_socket. We can hardwire socket_per_node=1 for the moment.

anybody is working on this? if no, i will take it.


Xen-devel mailing list