This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] [PATCH] xm --version

To: "aq" <aquynh@xxxxxxxxx>
Subject: RE: [Xen-devel] [PATCH] xm --version
From: "Ian Pratt" <m+Ian.Pratt@xxxxxxxxxxxx>
Date: Thu, 9 Jun 2005 02:18:07 +0100
Cc: Xen Dev <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 09 Jun 2005 01:17:17 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcVsj4brNdUa7lYeSIm1+kc+EB18EAAATXwA
Thread-topic: [Xen-devel] [PATCH] xm --version
> can you confirm that ht_per_core is also wrongly set? it is 
> set (=1) at arch/x86/setup.c or arch/ia64/smpboot.c, but 
> never changed. but this variable is used somewhere, and got 
> reported in "xm info", for example.
> so all of its usage are also wrong when we use HT? (because 
> in that case ht_per_core must be 2)

OK, that's bad -- the code that initialised ht_per_core has also gone.

What we need to do is to take the new code from Linux 2.6.12-rc5 that
understands multicore, and correctly initialise ht_per_core and
core_per_socket. We can hardwire socket_per_node=1 for the moment.


Xen-devel mailing list