This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] export symbols in Xeno-linux 2.6.11

To: <Xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-devel] export symbols in Xeno-linux 2.6.11
From: Zhiyi Huang <zhiyi6@xxxxxxxxxx>
Date: Mon, 6 Jun 2005 22:49:36 +1200
Delivery-date: Mon, 06 Jun 2005 10:49:02 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Organization: Univ of Otago
Reply-to: hzy@xxxxxxxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
I am trying to use some functions such as xen_l1_entry_update
in xeno-linux 2.6.11 in a module. I have changed the source
to export the symbols using EXPORT_SYMBOL and recompiled the
kernel of course. However, when I 
compile my module I have got a warning: "xen_l1_entry_update 
undefined" and when I load the module I have got an error of
unknown symbol.
Can anyone kindly point out some possible steps I should follow 
but I didn't?

Zhiyi from EPFL Switzerland

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] export symbols in Xeno-linux 2.6.11, Zhiyi Huang <=