This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: Using Debian packages

> Close, but not quite.
> You can take a vanilla 2.6.10 or the Debian patched 2.6.10. I would
> recommend the Debian patched one. You uncompress the kernel-source
> somewhere, copy in your .config, that is fine.
> The command you wish to run is:
>   make-kpkg --added-patches=xen --arch=xen --subarch=xen0
> --revision=xenserver.0.1 debian
> This patches the kernel and creates the ./debian directory in your
> source. After that you can run:
>   make ARCH=xen menuconfig
> And tune it to your liking. And after that, you compile the kernel:
>   make-kpkg --added-patches=xen --arch=xen --subarch=xen0
> --revision=xenserver.0.1 kernel-image
> And you are done. Not all of the flags need to be present in all
> phases, but it doesn't hurt either. Do also note that make-kpkg has
> some problems with --initrd combined with --arch=xen, so don't do
> that.

Thanks a lot for outlining the steps above.

But since I haven't succeeded in getting any xen kernel to boot yet, I 
probably need to spell out what I've done so far (at least for my self)...
I haven't really used grub until now, so maybe that's a reason to my troubles.

I was able to compile and install the kernel for dom0.
After install /boot directory now looks like this:

-rw-r--r--   1 root root  542011 Jan 20 03:47 System.map-2.4.27-2-386
-rw-r--r--   1 root root  546234 Mar 18 00:35 System.map-2.6.10
-rw-r--r--   1 root root       0 Mar 18 17:47 bootdir.txt
-rw-r--r--   1 root root   44853 Jan 20 02:53 config-2.4.27-2-386
-rw-r--r--   1 root root   25807 Mar 18 00:23 config-2.6.10
drwxr-xr-x   2 root root    1024 Mar 18 16:08 grub
-rw-r--r--   1 root root 3878912 Mar 18 16:07 initrd.img-2.4.27-2-386
drwxr-xr-x   2 root root   12288 Mar 18 16:03 lost+found
-rw-r--r--   1 root root      39 Mar 18 00:35 patches-2.6.10
-rw-r--r--   1 root root  816260 Jan 20 03:47 vmlinuz-2.4.27-2-386
-rw-r--r--   1 root root  115165 Mar 18 17:08 xen-linux-2.6.10

And I manually added this to /boot/grub/menu.lst:

title  XenLinux 2.0.5
root  (hd0,0)
kernel /boot/xen.gz dom0_mem=131072
module /boot/xen-linux-2.6.10 root=/dev/sda6 ro console=tty0

Nomatter what I've done so far I get grub error 15:

15 : File not found
This error is returned if the specified file name cannot be found,
but everything else (like the disk/partition info) is OK.

I more or less just pasted the menu.lst from documentation with a few changes. 
And noticed that xen kernerl xen.gz is missing in /boot directory. I've then 
tried to copy xen.gz from xen binary distribution, but I still get error 15.

Any help is really appriciated since I've been struggling with this for quite 
a while.

Med venlig hilsen / Best regards
Lars E. D. Jensen 

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Xen-devel mailing list