[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 02/15] x86/msr: Move rdtsc{,_ordered}() to <asm/tsc.h>
- To: "Xin Li (Intel)" <xin@xxxxxxxxx>
- From: Ingo Molnar <mingo@xxxxxxxxxx>
- Date: Fri, 2 May 2025 10:18:30 +0200
- Cc: linux-kernel@xxxxxxxxxxxxxxx, kvm@xxxxxxxxxxxxxxx, linux-perf-users@xxxxxxxxxxxxxxx, linux-hyperv@xxxxxxxxxxxxxxx, virtualization@xxxxxxxxxxxxxxx, linux-pm@xxxxxxxxxxxxxxx, linux-edac@xxxxxxxxxxxxxxx, xen-devel@xxxxxxxxxxxxxxxxxxxx, linux-acpi@xxxxxxxxxxxxxxx, linux-hwmon@xxxxxxxxxxxxxxx, netdev@xxxxxxxxxxxxxxx, platform-driver-x86@xxxxxxxxxxxxxxx, tglx@xxxxxxxxxxxxx, mingo@xxxxxxxxxx, bp@xxxxxxxxx, dave.hansen@xxxxxxxxxxxxxxx, x86@xxxxxxxxxx, hpa@xxxxxxxxx, acme@xxxxxxxxxx, jgross@xxxxxxxx, andrew.cooper3@xxxxxxxxxx, peterz@xxxxxxxxxxxxx, namhyung@xxxxxxxxxx, mark.rutland@xxxxxxx, alexander.shishkin@xxxxxxxxxxxxxxx, jolsa@xxxxxxxxxx, irogers@xxxxxxxxxx, adrian.hunter@xxxxxxxxx, kan.liang@xxxxxxxxxxxxxxx, wei.liu@xxxxxxxxxx, ajay.kaher@xxxxxxxxxxxx, bcm-kernel-feedback-list@xxxxxxxxxxxx, tony.luck@xxxxxxxxx, pbonzini@xxxxxxxxxx, vkuznets@xxxxxxxxxx, seanjc@xxxxxxxxxx, luto@xxxxxxxxxx, boris.ostrovsky@xxxxxxxxxx, kys@xxxxxxxxxxxxx, haiyangz@xxxxxxxxxxxxx, decui@xxxxxxxxxxxxx, dapeng1.mi@xxxxxxxxxxxxxxx, ilpo.jarvinen@xxxxxxxxxxxxxxx
- Delivery-date: Fri, 02 May 2025 08:18:55 +0000
- List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
* Xin Li (Intel) <xin@xxxxxxxxx> wrote:
> For some reason, there are some TSC-related functions in the MSR
^^^^^^^^^^^^^^^
> header even though there is a tsc.h header.
The real reason is that the rdtsc{,_ordered}() methods use the
EAX_EDX_*() macros to optimize their EDX/EAX assembly accessors, which
is why these methods were in <asm/msr.h>.
Your followup patch tacitly acknowledges this by silently creating
duplicate copies of these facilities in both headers ...
I've cleaned it all up in tip:x86/msr via these preparatory patches:
x86/msr: Improve the comments of the
DECLARE_ARGS()/EAX_EDX_VAL()/EAX_EDX_RET() facility
x86/msr: Rename DECLARE_ARGS() to EAX_EDX_DECLARE_ARGS
x86/msr: Move the EAX_EDX_*() methods from <asm/msr.h> to <asm/asm.h>
Thanks,
Ingo
|