[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] xen-blkfront: Use the bitmap API when applicable



Le 02/12/2021 à 07:12, Juergen Gross a écrit :
On 01.12.21 22:10, Christophe JAILLET wrote:
Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
open-coded arithmetic in allocator arguments.

Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
consistency.

Use 'bitmap_copy()' to avoid an explicit 'memcpy()'

Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx>
---
  drivers/block/xen-blkfront.c | 8 +++-----
  1 file changed, 3 insertions(+), 5 deletions(-)

diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
index 700c765a759a..fe4d69cf9469 100644
--- a/drivers/block/xen-blkfront.c
+++ b/drivers/block/xen-blkfront.c
@@ -442,16 +442,14 @@ static int xlbd_reserve_minors(unsigned int minor, unsigned int nr)
      if (end > nr_minors) {
          unsigned long *bitmap, *old;
-        bitmap = kcalloc(BITS_TO_LONGS(end), sizeof(*bitmap),
-                 GFP_KERNEL);
+        bitmap = bitmap_zalloc(end, GFP_KERNEL);
          if (bitmap == NULL)
              return -ENOMEM;
          spin_lock(&minor_lock);
          if (end > nr_minors) {
              old = minors;
-            memcpy(bitmap, minors,
-                   BITS_TO_LONGS(nr_minors) * sizeof(*bitmap));
+            bitmap_copy(bitmap, minors, nr_minors);
              minors = bitmap;
              nr_minors = BITS_TO_LONGS(end) * BITS_PER_LONG;
          } else

Shouldn't you use bitmap_free(old) some lines down?

Obvious.
I'll send a V2, Thx for the review.

CJ


@@ -2610,7 +2608,7 @@ static void __exit xlblk_exit(void)
      xenbus_unregister_driver(&blkfront_driver);
      unregister_blkdev(XENVBD_MAJOR, DEV_NAME);
-    kfree(minors);
+    bitmap_free(minors);
  }
  module_exit(xlblk_exit);


Juergen





 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.